The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpmyadmin is broken

Discussion in 'Database Discussions' started by AbeFroman, Sep 23, 2003.

  1. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    I just setup a new server with mysql 4 installed.

    When my customers are trying to access phpmyadmin it's saying access denied
    wrong username/password.

    What's wrong and how do I fix this ?

    cPanel.net Support Ticket Number:
     
  2. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    Anyone else have this problem?

    cPanel.net Support Ticket Number:
     
  3. iD. Joel

    iD. Joel Member

    Joined:
    Sep 24, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    I am also having this problem, help appreciated.

    cPanel.net Support Ticket Number:
     
  4. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca
    Are you sure the pass in /root/.my.cnf is correct root pass for mysql?

    cPanel.net Support Ticket Number:
     
  5. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    I'm experiencing the same sorts of things... last night, all was well, today, phpMyAdmin refuses accept the username:password being passed by cpanel when a user is logged in.

    I've searched through the forums quite a bit, have tried the fix mentioned here as well as others, all to no avail.

    I'm using;

    WHM 8.5.4 cPanel 8.5.4-R72
    RedHat 8.0 - WHM X v2.1.1
    mysql (4.0.15-standard)
    phpMyAdmin 2.5.2

    I haven't installed anything or changed anything that I am aware of, from what was working fine for the last 2 weeks I've had this box.

    I don't seem I'm the only one encountering this, though some of the posts I've read are quite old and apply to earlier versions of cpanel.

    Is there a definitive fix?

    Thanks,
    verdon
     
  6. d00t

    d00t Member

    Joined:
    Sep 13, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    was there ever a fix for this?

    I've got 3 brand new servers all on different hosts with the same problem.
     
  7. Tas

    Tas Member

    Joined:
    Nov 18, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
  8. d00t

    d00t Member

    Joined:
    Sep 13, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    thanks for the speedy reply,

    however that did not work
     
  9. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    Set the mysql root pass to
    asdfasdf234

    /scripts/updatenow
    /scripts/upcp
     
  10. balakrishnan

    balakrishnan Member

    Joined:
    Sep 13, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    phpnyadmin : access denied

    Go to the WHM and reset the password for the acount.. in change password of accounts.. it should be workin fine then.
     
  11. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    you can also try reset the password for root for mysql.
     
  12. daWeazy

    daWeazy Member

    Joined:
    Jan 1, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    California
    I myself have the same issue and have tried very listed option, idea to fix this issue. It only started within the last few days. I am currently on:

    WHM 9.9.0 cPanel 9.9.2-C6
    Fedora i686 - WHM X v3.1.0
    Welcome to phpMyAdmin 2.6.0-pl1

    Wrong username/password. Access denied.

    Running "CURRENT" Release on Fedora Core 2

    Anyhelp would be so appreciated!

    Could this be related to any php.ini file options? Any options in /etc/my.cnf ?etc.. let me know!
     
  13. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I've the same problem:

    Of course I've:

    Change password and restart mysql.
    /root/.my.cnf without ""
    Run /scripts/upcp

    Don't work.
     
  14. paolorulez

    paolorulez Guest

    remove the quote in .my.cnf

    "user"
    "password"

    to

    user
    password

    flush table and restart mysql, after phpmyadmin work fines
     
  15. daWeazy

    daWeazy Member

    Joined:
    Jan 1, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    California
    OK I found a fix. Let me know if this works:

    SSH to your server as Root:

    type: cd /var/lib/mysql

    type: ln -s /tmp/mysql.sock mysql.sock

    Hit enter, then test phpMyAdmin.

    Good luck. It fixed me.
     
  16. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Dou you read pots [paolorulez ]?
    Thanks for de post with lsymbolic link.

    But after upgrade to latest version problem dissapears.
     
  17. paolorulez

    paolorulez Guest

    after change pass or remove quote

    run flush privileges

    mysql> FLUSH PRIVILEGES;

    ------------

    shell> mysql -u root

    mysql> UPDATE mysql.user SET Password=PASSWORD(newpwd)
    -> WHERE User=root;
    mysql> FLUSH PRIVILEGES;
     
    #17 paolorulez, Oct 12, 2004
    Last edited by a moderator: Oct 12, 2004
  18. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Actually I fixed it, so I edited this message. :p
     
    #18 DWHS.net, Jul 29, 2005
    Last edited: Jul 29, 2005
  19. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Out of interest, what was the fix? I'm kinda getting stuck with similar issues . . .
     
Loading...

Share This Page