The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpMyAdmin - "Logged in as root user" error

Discussion in 'Database Discussions' started by digitalfire, Nov 21, 2004.

  1. digitalfire

    digitalfire Member

    Joined:
    Nov 18, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I can't access phpMyAdmin, when I log into cPanel with my (reseller) account - there are 2 reseller accounts on my box, and root. When I login to cPanel (not WHM!) and go to "MySQL Databases" it gives me the page listing my MySQL user accounts and Databases, with the "phpMyAdmin" link at the bottom.

    Then I click on the "phpMyAdmin" link I opens a new page, which says:
    I've tried logging into cpanel with the other reseller's account, and can access phpMyAdmin for his account(/site) fine - it just seems to be mine giving problems.

    It does, for some reason, say "Warning: You are logged in using the reseller or root password" at the top of the cPanel page when I'm logged in - but I didn't create my account with root-privileges or anything like that (I've even checked my account settings by loging into WHM as root and modifying my account, and checking my reseller settings).

    Any advice, or am I just doomed and going to be unable to work on my own DB?

    Thanks!

    digitalfire
     
    #1 digitalfire, Nov 21, 2004
    Last edited: Nov 21, 2004
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Just wondering if your reseller and root passwords are the same? If so, try making them different. If not, ignore me ;)
     
  3. digitalfire

    digitalfire Member

    Joined:
    Nov 18, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    *ahem*

    So I figured it out - though I have to admit I can't belive cPanel is so restrictive. Naturally the answer was right in front of me - I'm probably just to in-experienced to realise it. The warning said "You are logged in using the reseller or root password", and it wasn't kidding.

    I wasn't using the root account, I just happened to have the same password for my account (for convenience)... isn't that some what of a security issue, consider the "Change Password" option? All an ordionary user has to do, is keep chaning his password, guessing at a reseller or root password, until he get's the warning, and suddenly he has access to other accounts?!?!

    Anyway, despite phpMyAdmin being disabled (by cPanel, not a phpMyAdmin issue) I could still type (or copy and paste) the exact URL to phpMyAdmin and it worked fine - once again, great security?

    So my account's working properly again, and I've (had to) changed my root password to something un-thinkable to ensure none of my users "guess" it by chance and take over my box.

    digitalfire
     
  4. digitalfire

    digitalfire Member

    Joined:
    Nov 18, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your reply chirpy - sorry I was so busy having my bitch I didn't notice you'd replied, but yes - that was the problem! :P

    A little testing has proven me wrong - cPanel only seems to associate a reseller account, with the root account, if it's created by root, and has the password set to the root password (by root). So a user/reselller setting their password to your root password wont be a problem, as I originally thought.

    Interesting though... I obviously haven't read the cPanel documentation carefully enough *innocent whistle*

    digitalfire
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I agree that it's curious behaviour, but they have their little way's with cPanel ;)
     
Loading...

Share This Page