The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpMyAdmin No Privileges

Discussion in 'Database Discussions' started by Dr.Death, Oct 20, 2006.

  1. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I have some problem with mysql and phpmyadmin, I cant create DB with phpmyadmin, it show me "No Privileges", I changed the privilege to full from WHM phpMyAdmin. and still the same.

    I tried to install phpBB and joomla, i create the DataBase from the cpanel and asign a user to it,
    But no connection to the DB. i tried also with the root user and password but no chance.

    From the command line i can connect to the DB "mysql -u -p DB", but not from the install.php file for phpBB and joomla.

    Server info:
    mysql error message:
    phpMyAdmin message:
    sorry for my bad English.

    Thankx
     
    #1 Dr.Death, Oct 20, 2006
    Last edited: Oct 20, 2006
  2. Manuel_accu

    Manuel_accu Well-Known Member

    Joined:
    Jun 19, 2005
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    16
    Which version of MySQL are you using?


    Also provide php version and my.cnf configuration details.

    It seems you need to grant some access to related databases.

    Thanks,
     
  3. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi manuel,

    MySQL version 4.1.21
    PHP version 4.4.4
    phpMyAdmin 2.9.0.2

    my.cnf :
    by defual Global privileges was set to "USAGE", Grant not enabled.
    I enable all Global privileges options "Data, Structure, Administration" and Grant.

    Still the same error messages appear.

    Thankx
     
  4. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I fixed the problem, the problem was that MySQL 4.1 and 5.0 require a different password exchange protocol than PHP prior to 5.x uses.
    here is mysql doc. : http://dev.mysql.com/doc/refman/5.0/en/old-client.html

    i add this line to /etc/my.cnf:

    old-passwords = 1


    also upgrade Mysql to V5.0.18

    Its work fine now, thankx
     
  5. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    but still i need to add Grant privilege manually to the users.

    any idea how to make it set by defualt !
     
Loading...

Share This Page