Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

phpPgAdmin always showing login failed

Discussion in 'Database Discussion' started by zaher, Aug 20, 2014.

  1. zaher

    zaher Active Member

    Joined:
    Jul 2, 2014
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello Sir,

    Suddenly, as I try to access phpPgAdmin i get Login Failed.

    I checked phpPgAdmin configuration file (“conf/config.inc.php”) and adjusted:
    Code:
    $conf['servers'][0]['host'] = '' 
    To
    Code:
    $conf['servers'][0]['host'] = 'localhost'
    Also I tried with $conf['extra_login_security'] being false and true.

    The pg_hba.conf file is as such
    Code:
    local samerole all        md5   
    host samerole all  127.0.0.200   255.255.255.255   pam  pamservice=postgresql_cpses 
    host samerole all  127.0.0.1   255.255.255.255   md5   
    local all postgres        md5 
    host all postgres  127.0.0.1   255.255.255.255   md5   
    host all all  ::1/128  md5
    I also tried adding the following without success
    Code:
    local all all trust
    Anything I am missing?
     
  2. server9host

    server9host Well-Known Member

    Joined:
    Sep 18, 2013
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    Please post screenshot for phpAdmin access issue for further assistance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please browse to:

    "WHM Home » SQL Services » Configure PostgreSQL"

    Click on the "Install Config" and "Create Users" options and then restart PostgreSQL. If the issue persists, please open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. zaher

    zaher Active Member

    Joined:
    Jul 2, 2014
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I had come accorss this while troubleshooting, but didn't do it because it says
    Are you sure I need to apply this?
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    It simply reverts your pg_hba.conf file to default, which is fine if you have made no custom changes (other than the ones you took when attempting to resolve the issue).

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice