phpPgAdmin do not work any more in 11.28.28

kjg

Well-Known Member
Mar 2, 2004
158
3
168
After upgrade, accessing databases via cpanel - phpPgAdmin do not work any more

I see the databases, and when clicking one of them, I can see tables etc

I cannot see any data in the databases and not run SQL queries

In the left column there is only the text Servers and under that a X-d database icon plus the text PostgreSQL

Usually this expands into the different databases on the account and down via public - tables etc

The only thing happening when clicking "PostgreSQL" in left column is that the login form shows for a second or two in right column (main window) and after that the list of DB is shown in the right column.
Same thing if I click any of the database names and the "public" row is shown to the right. Etc etc In the left column, nothing happends.

But, I cannot browse any data, nor change, insert, query etc. And since I cannot open privileges settings, I cant add user or check settings

Is there another way to open phpPgAdmin until this is fixed?

// kjg
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
Updated:
Tested on another server and the same error occurs.

Tested with and without SSL and the same error occurs.

Server info:
Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5
CentOS 5.5
WHM 11.28.28 (or 11.28.15 as it say in change log)
PostgreSQL 8.1.22
suphp
php 5.2.14

// kjg
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
Update again:
Tested to add the database via the Database Map Tool in WHM, but no success

Same error still.

Would really appreciate if someone could give me a hint in how to solve this. Our users really need to have phpPgAdmin access to the databases.

// kjg
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
For all of you that have the same issues, here are some good news:

I opened a support ticket for this and just got the reply:

"This issue has been repaired in the latest RELEASE build, if you run a '/scripts/upcp --force' this issue should be resolved."

//kjg
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
Unfortunately the new build did not solve the phpPgAdmin issue as it was supposed to do.

Upgraded all servers to 11.28.35 but it did not help.

Still no account can use phpPgAdmin

I am waiting for the cPanel support to give a new reply on this issue, but until then: If anyone has a solution on how to bypass the problem it would be appreciated.

// kjg
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
The latest response I got in the ticket was:

"I've replicated this behavior on a test server and created internal case #44688"

So I guess that is the number you need? Or?

// kjg
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
Thanks, I was able to find your ticket number in the case. I will keep watching as it progresses to make sure you get resolution.
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
Got another reply yesterday from the excellent cPanel support staff.
It seems this is a browser related issue.

If you use Chrome, it works fine.

So until it is fixed in a coming release, you can use chrome.

// kjg
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
76
308
cPanel Access Level
Root Administrator
This should be resolved in our next 11.28 build. There was some javascript doing the wrong thing, which would result in logging the user out of phpPgAdmin.
 

deddy

Well-Known Member
Oct 13, 2003
145
1
168
Re: phpPgAdmin does not work anymore in 11.28.28

Chrome is no longer working since update to 11.28.39
In the meantime a real desaster.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
The fixed for this issue was merged into 11.28 @ 11/17/2010 (Today) 11:13 AM Central Time. It should be available in the next public 11.28 build.
 

deddy

Well-Known Member
Oct 13, 2003
145
1
168
Re: phpPgAdmin does not work anymore in 11.28.28

No access to database(s).
phpPgAdmin page blinks as soon as open
although username/password seems to be
available now.

We return to stable where necessary.
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Re: phpPgAdmin does not work anymore in 11.28.28

No access to database(s).
phpPgAdmin page blinks as soon as open
although username/password seems to be
available now.

We return to stable where necessary.
To the best of my knowledge the phpPgAdmin difficulty discussed in this thread should be fully resolved as of cPanel 11.28.42, while the latest available version is cPanel 11.28.45 as of the time of writing. I recommend to ensure that your cPanel installation is using the latest version available with automatic updates enabled. While it always an option to switch between update tiers, I would not consider reverting to a different update tier when it involves a significant downgrade (e.g., from 11.28 down to 11.26).
 
Last edited by a moderator:

deddy

Well-Known Member
Oct 13, 2003
145
1
168
I'm so sorry but it is still not working.

Current version 11.28.45
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
Works fine from here
I am using Firefox and Chromium as browsers

If you have not already, try clearing browsers cache

// kjg
 

deddy

Well-Known Member
Oct 13, 2003
145
1
168
Re: phpPgAdmin does not work anymore in 11.28.28

Thanks. I was able to find the difference.

:2082 is working
:2083 is not working
 

kjg

Well-Known Member
Mar 2, 2004
158
3
168
Hi deddy
We never use anything else than 2083 so it is working using 2083 for us

// kjg