The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phppgadmin problems

Discussion in 'General Discussion' started by QurazyQuisp, Jun 30, 2008.

  1. QurazyQuisp

    QurazyQuisp Registered

    Joined:
    Jun 30, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I'm currently having problems with phppgadmin.

    I can create delete modify databases via cpanel, however, when I try to use phppgadmin, under servers PostgreSQL has a red x next to it. I try to login with both root and postgres and it says that the users are not allowed for security reasons.

    This is very frustrating, as it renders postgresql basically useless. (I haven't had much luck with pgadmin either)

    Does anyone have any idea what I can do?
     
  2. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    hey, have you been able to get this sorted out?
     
  3. Danks

    Danks Active Member

    Joined:
    Oct 10, 2001
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    My fix was editing /var/lib/pgsql/data/pg_hba.conf and moving the last two lines

    Code:
    local   all             all     md5
    host    all             all     127.0.0.1 255.255.255.255       md5
    
    above the commented line
    Code:
    # "local" is for Unix domain socket connections only
    
    then restarting with /scripts/restartsrv_postgres
     
  4. Sabaote

    Sabaote Well-Known Member

    Joined:
    Dec 19, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ribeirao Preto, Brazil
    Thanks Danks..

    it really worked :)
     
  5. chaitanya

    chaitanya Registered

    Joined:
    Mar 28, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    PhpPgAdmin root login access

    PostgraceSqlPhpPgAdmin login failed root not able to login
    ====================================
    If you are keep getting "login failed".error while accessing the PhpPgAdmin you have to follow the setp below

    1.Edit vi /var/lib/pgsql/data/pg_hba.conf like below:

    local all all md5
    host all all 127.0.0.1 255.255.255.0 md5
    ~
    ~3
    2. Save this & restart the PostgraceSql using
    /etc/init.d/postgresql restart
    =============================================================

    By default the root access is denied on PhpPgAdmin. If you want it enable it all you need to do is login as root change

    it to False as given below

    #$conf['extra_login_security'] = true;
    $conf['extra_login_security'] = false;

    Note: You need to have root access on your Server
     
  6. jba_21

    jba_21 Registered

    Joined:
    Sep 30, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Thanks! it works.
     
Loading...

Share This Page