The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpsuexec still unroutable?

Discussion in 'General Discussion' started by sexy_guy, Apr 17, 2003.

  1. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Well i certainly did not expect to see a return path of nobody@mydomain.com that bounced back as unroutable today espeically after i installed phpsuexec. Why is this still happening? The user sent out his email from his username@hisdomain but it bounced back to me?

    With phpsuexec installed im wondering why i received 3 msgs bounced back to nobody@mydomin.com today??? I have the option checked in WHM also. :confused:

    Another thing, msgs are still going out as username@srv1.domain.com instead of username@theusersdomain.com? Is this correct under phpsuexec? I dont think it should be sending my hostname out under phpsuexec should it?
     
  2. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    What I'm wondering..instead of fixing the problems with the new exim versions and user nobody, they push everyone into running php as cgi and running phpsuexec.

    The only reply to a support ticket I got on the 'exim and user nobody' subject was this answer (after explaining my settings and errors in detail) :
    And just being ignored after that.. :(

    Does installing phpsuexec mean people have to handle files the same way as cgi files (uploading in ASCII mode and chmodding to 755) ?
    I don't think users would be too happy with that, after all that's one of the reasons why people prefer php over perl.

    I just wish DarkOrb would give more priority on testing and fixing problems instead of adding new features.

    exim-3.36-101_cpanel_stmpcontrol_antivirus works fine with php forms.
    exim-3.36-121_cpanel_stmpcontrol_antivirus just doesn't work as it should, either the messages are bounced or they are put in the queue and are sent out once an hour.

    I hope they will look into this instead of just telling people to install phpsuexec.
     
  3. Stenny Chong

    Stenny Chong Well-Known Member

    Joined:
    Jun 12, 2002
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Are you sure your have phpsuexec install properly, if yes you should found there is a "PHP-CGI/0.1b" within your /etc/httpd/logs/error_log file.
     
  4. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I have it install properly, im still having unroutable domain errors



    This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    bradcates@earthlink.net
    unrouteable mail domain "earthlink.net"

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <nobody@xx>

    With a return path of nobody

    After 36hrs of installing phpsuexec
     
  5. Stenny Chong

    Stenny Chong Well-Known Member

    Joined:
    Jun 12, 2002
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    maybe it is some old mail dying before you install phpsuexec, wait some more time to see how going on...

    :)
     
  6. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I have phpsuexec installed and "Prevent the user 'nobody'" checked. Im still getting lots of unroutable domain errors.

    unrouteable mail domain "msn.com"
    unrouteable mail domain "hotmail.com"
    unrouteable mail domain "hotmail.com"

    etc

    and msgs coming back to nobody@myhostname.com.

    I though phpsuexec was supposed to fix this.
     
  7. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    2003-04-22 17:34:09 1988D8-0003RE-00 ** garyhollandpa@comcast.net: unrouteable mail domain "comcast.net"
    2003-04-22 17:34:09 1988DB-0003RZ-00 <= <> R=1988D8-0003RE-00 U=root P=local S=5031

    WTF is everyone elses setup different to mine? I would really like to know. Why unroutable why why why! Im frustrated to no end with this thing!!
     
  8. h2oski

    h2oski Well-Known Member

    Joined:
    Dec 12, 2001
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    sexy_guy,

    with all the mail problems you are having I wonder if perhaps it is a reverse DNS issue with your server.

    use the reverse dns lookup tool on this page http://www.dnsstuff.com/

    enter your main server ip address and see what it says.
     
  9. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    You could do find / -user nobody -type f to see what files are owned by nobody and see if their are any potientally mail sending scripts in the results you will ideally need to do this as root otherwise you will get screenful of permission denied) you could also verify that the phpsuexec patch got properly installed by doing grep PHPHANDLER /usr/local/apache/bin/suexec (if you get binary file suexec matches then it is installed ok)
     
  10. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    You know what, you may have hit the nail on the head. I LOVE YOU! :p
     
  11. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I dont love you after all :D I am still getting bounced messages and unroutable domain errors with phpsuexec installed. This is absolutely nuts! NUUUTTTSSSSSSSSSSSSSSSSSSS! My boxes dont have the reverse ptr problem now yet this is still going on day after day after day without any fix.
     
  12. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    *BUMP*
    *BUMP*
    *BUMP*

    Mail Delivery System Wed, 8:20 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 8:19 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 8:15 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 8:09 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 8:05 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 8:05 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:57 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:49 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:48 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:48 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:46 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:45 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:27 pm Mail delivery failed: returning message to sender
    Mail Delivery System Wed, 7:00 pm Mail delivery failed: returning message to sender
     
    #12 sexy_guy, Apr 23, 2003
    Last edited: Apr 23, 2003
  13. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    After recompiling apache for about the 5th time in a week, and re-adding Phpsuexec as an option, i am once again getting unroutable domain errors. Most of those unrouatables are to my own domain on my other box. WHY!?!?!?!!? Why cant the box with phpsuexec installed send mail to my box that doesnt have phpsuexec installed DUH! It resolves. DNS is just fine. This is shamless!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
     
  14. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Would it be correct to assume that your phpsuexec machine was the srv01 mentioned in http://forums.cpanel.net/showthread.php?s=&threadid=9076 if so then a probable reason for it being rejected by the non-phpsuexec machine is that it fails the sender_verify test since according to the nameservers for the fastserver.com domain the srv01.fastserver.com record does not exist

    Of course if it isn't your machine then the above would not be relevant
     
  15. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I wish that was the case but i only edited those nameserver with anything. They are not real nameservers names. Our servers numbers and names are very different to those edited.
     
  16. Titi

    Titi Registered

    Joined:
    May 28, 2002
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Have you solved this issue?

    cPanel.net Support Ticket Number:
     
  17. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    I am still experiencing this problem, no fix.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page