The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpSuExec turned on but user is "nobody"

Discussion in 'General Discussion' started by bobbybobbertson, Jun 8, 2012.

  1. bobbybobbertson

    bobbybobbertson Well-Known Member

    Joined:
    May 30, 2003
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Below is my current configuration as seen in whm >> Configure PHP and SuExec.

    It shows that Apache suEXEC is turned on. However if I put in my php file "<?php echo `whoami`;?>, it outputs the user "nobody".

    Do I need to turn on Apache Ruid2? If so, how do I do so as I don't have the option under "Alter Configuration".


    Current Configuration

    Option Configured Value
    Default PHP Version (.php files) 5
    PHP 5 Handler dso
    PHP 4 Handler none

    Apache suEXEC on
    Apache Ruid2 off


    Alter Configuration

    Option Value
    Default PHP Version (.php files)
    PHP 5 Handler
    PHP 4 Handler

    Apache suEXEC
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    you need to recompile Apache with easyapache and check Ruid2
     
  3. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
Loading...

Share This Page