The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpsuexec

Discussion in 'General Discussion' started by jbix9, Aug 30, 2003.

  1. jbix9

    jbix9 Member

    Joined:
    Jan 7, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Yet another thread about phpsuexec. I have installed phpsuexec and webroot protection. I love being able to track down scripts now. However with the webroot protection public_html is chmod 750 and group changed to nobody. If I put a php (or cgi too) script in /home/user/public_html I get internal server errors. I can chown a folder and its subfolders and files to the correct user and group and php scripts will run fine under phpsuexec in public_html. However, an individual php file has to be placed in the cgi-bin to work which is not desirable. I have tried all sorts of chowns and chmods and nothing has worked thus far. Do I have to disable webroot protection? I really like that feature. What am I missing here? :confused:

    cPanel.net Support Ticket Number:
     
  2. roman

    roman Well-Known Member
    PartnerNOC

    Joined:
    Feb 13, 2002
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ran into the same problem..

    Had to turn off the option and alter a script to adjust everyone's public_html to their ownship and change the chmod back to 711 ..

    -- BUT --

    I am also having a problem with front page extension installations from the control panel (2082) which seems to change the other ownership and chmod as well.. The only fix I have is to install frontpage extensions manually... Which is not a solution..

    Anyone else run into this problem? Am I missing something too.. ? :)

    cPanel.net Support Ticket Number:
     
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    so webroot protection doesn't permit to run php/cgi files on /public_html and restricts usage only to cgibin?

    Please may we know more ?

    cPanel.net Support Ticket Number:
     
  4. Azer

    Azer Member

    Joined:
    May 25, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    After update Apache with phpsuexec enabled option i saw in process list following:

    postsuexecinstall - searching for suexec problems (815 minute)

    Is it normal situation? PHP seems work normal but i am affraid that phpsuexec wodn't work correctly...

    cPanel.net Support Ticket Number:
     
  5. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    postsuexecinstall - searching for suexec problems (815 minute)

    That is normal...

    Basically, it searches for PHP scripts with the wrong permissions.

    But I use Phpsuexec and Webroot protection and they both work fine...

    You must have some other problem...

    cPanel.net Support Ticket Number:
     
  6. DHL

    DHL Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    What OS are you running? I have similar problems, but only with Redhat 9.

    cPanel.net Support Ticket Number:
     
  7. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    That could be it...

    We are using Red Hat 7.3

    cPanel.net Support Ticket Number:
     

Share This Page