The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PICS in Bermuda Triangle!

Discussion in 'General Discussion' started by n1tr0, Apr 18, 2008.

  1. n1tr0

    n1tr0 Member

    Joined:
    Apr 18, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NY
    I uploaded a site that was working fine in my old server, but now the GIF or JPEG or ANY OTHER PICTURE for that matter, refuses to show up on my page.
    Everything else works.
    I build and continue to add to this site with Dreamweaver CS and everything works during the test.
    I have all files in /public_html/ all under addon site ( .checkthespot.com ).
    I can see the images fine when I put the link in IE. http://www.checkthespot.com/images/ THEN images/BouncyBall_1.gif and so on, but when I open the page, the image does not load even though everything else (text, links etc) work fine.

    PLS HELP!!!:(
     
  2. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Contact your web hosting provider so they can look at the machine to see if everything is configured properly and if they can duplicate the problem.

    If you dont want to do that then check your source code and be sure you are calling the files from the proper folder paths. Be sure you uploaded them correctly in binary, etc..
     
    #2 nyjimbo, Apr 18, 2008
    Last edited: Apr 18, 2008
  3. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    I have this kind of problem a few years ago and it happen because i uploaded with ascii mode. Switch to binary mode and upload again fix my problem. :D
     
  4. n1tr0

    n1tr0 Member

    Joined:
    Apr 18, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NY
    THIS IS WHAT I FOUND ON DREAMWEAVER HELP MENU
    Changing FTP mappings
    The FTPExtensionMap.txt file (Windows) and the FTPExtensionMapMac.txt file (Macintosh) map filename extensions to FTP transfer modes (ASCII or BINARY).

    Each line in each of the two files includes a filename extension (such as GIF) and either the word ASCII or the word BINARY, to indicate which of the two FTP transfer modes should be used when transferring a file with that extension. On the Macintosh, each line also includes a creator code (such as DmWr) and a file type (such as TEXT). When you download a file with the given filename extension on the Macintosh, Dreamweaver assigns the specified creator and file type to the file.

    If a file that you are transferring doesn't have a filename extension, Dreamweaver uses the BINARY transfer mode.

    Note: Dreamweaver cannot transfer files in Macbinary mode. If you need to transfer files in Macbinary mode, you must use another FTP client.

    The following example shows a line (from the Macintosh file) that indicates that files with the extension .html should be transferred in ASCII mode:

    HTML DmWr TEXT ASCII
    In both the FTPExtensionMap.txt file and FTPExtensionMapMac.txt file (Macintosh), all elements on a given line are separated by tabs. The extension and the transfer mode are in uppercase letters.

    To change a default setting, edit the file in a text editor.

    To add information about a new filename extension:
    1. Edit the extension-map file in a text editor.

    2. On a blank line, enter the filename extension (in uppercase letters) and press Tab.

    3. On the Macintosh, add the creator code, a tab, the file type, and another tab.

    4. Enter ASCII or BINARY to set an FTP transfer mode.

    5. Save the file.


    It did not help me. I added the (.PHP tab BINARY) using WordPad and all I got was the text ".PHP BINARY" on the page itself! I also played around with the (EDIT/FORMAT, CODE PREFERENCES) on Dreamweaver. Changed it around from CR LF for Windows, CR for Macs and LF for Unix systems.
    I also made new pages (checkthespot.com/test.php, test2.php, test3.php) but had the same problem. I did notice that the htm pages did not show the ".HTML BINARY" like the PHP pages (test3.php)
    Thanks for your help ppl...I'm pulling my hairs out over here!!!
     
  5. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    You really should be asking this on a web hosting forum at www.webhostingtalk.com or at a dreamweaver support board.

    This forum is for Cpanel/WHM support issues, what you are having is more related to your use of Dreamweaver and web design.
     
  6. n1tr0

    n1tr0 Member

    Joined:
    Apr 18, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NY
    Just in case

    Good point Jimbo. I will do that, but will also leave this here open too in case some1 has come across this problem. I will also post a solution if and when I find one.
    Thanks for your help!
     
  7. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    Wow, is that the code that Dreamweaver produces? Yikes.

    If the image is loading when you enter the url directly into the browser, it's not an upload issue. If the file was uploaded as text instead of binary, it would likely never load - directly or within HTML - since the file headers would be messed up.

    If you can, try the link to the image without the leading slash:
    Code:
    <img src="/images/images/Front_Page_motion_1.gif" width="600" height="450" />
    
    change to
    Code:
    <img src="images/images/Front_Page_motion_1.gif" width="600" height="450" />
    
    Also, if you are uploading to a linux box try to keep things all lowercase. Windows servers are more forgiving for case-sensitivity, but linux is pretty strict. "Front_Page_motion_1.gif" in your code when the file is saved server side as "front_page_motion_1.gif" will give you problems on a nix box. And if you're testing windows side all will look fine until you ftp the files server side.

    Hope these help. :)
     
  8. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    The files on the server seem to be 0 bytes in size. This is why they won't display.

    Check to make sure you have enough drive space or are uploading properly.
     

Share This Page