The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help ~ why am I seeing apache page?

Discussion in 'EasyApache' started by outeredge, Apr 26, 2007.

  1. outeredge

    outeredge Registered

    Joined:
    Apr 26, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have just installed cPanel on a clean Centos 4.4 Server. It is running on a vmware machine using host-only network with IP tables forwarding a single ip address to it.

    I have setup accounts for some sites however when i visit them all i recieve is the "Apache is working on your cPanel" page. Even after uploading files..?

    If I visit http://xxx.xxx.xxx.xxx/~username the site appears fine and working.

    Can anyone help? Please..
     
  2. larryl

    larryl Active Member

    Joined:
    Feb 19, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Things I would check:

    - check the name servers on the site registration to make sure they are either pointing to your name server or that the name server they point to are giving out the right IP address (I know you said you're getting the apache page, but lots of boxes have apache and it certainly wouldn't be the first time such a coincidence had occurred).
    - make sure the sites have a DNS zone. You can check this via WHM and directly in /var/named.
    - check httpd.conf to make sure the sites appear there.
    - restart httpd and try the sites again (just to be thorough - you usually don't have to do this)
    - look /etc/httpd/logs/access_log and /etc/httpd/logs/error_log while accessing a site to see what happens
     
  3. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Either the sites were setup on a different IP address than what your DNS is configured
    or you possibly have a mis-configured /etc/resolv.conf file.

    Check your /etc/httpd/conf/httpd.conf file and make sure that the site is
    actually in the vhost section of Apache's config file and also make a note
    of it's IP address and make sure that is what matches your DNS settings.
     
  4. outeredge

    outeredge Registered

    Joined:
    Apr 26, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks guys that worked - but..

    Hi Spiral,

    Thanks for pointing me in that direction - not sure why I didn't think of it.

    Ok - so the sites work now if I change the IP in httpd.conf to the ip of the machine (behind host-only forwarding) which is something like 192.168.29.XXX.

    The problem I have now is will I have to update the httpd.conf file EVERY time I add a site through cPanel? I can't set the sites to point at that address or DNS will go crazy - just apache.

    Is there anyway I can automate this?? Would love to get this sorted before tomorrow AM.

    Many thanks!!

    David
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    I can take a look if you would like
     
  6. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    If you are using NAT for your hosting, you'll get the wrong IP address in httpd.conf if your main shared IP is set to your public IP.


    We don't recommend NAT but you can switch the Main Shared IP to the internal IP to fix this.


    Warning: This will result in emails about your A entries being wrong. Also, running behind NAT can cause licensing issues.
     
Loading...
Similar Threads - Please help seeing
  1. deathy
    Replies:
    1
    Views:
    84
  2. DeepXP
    Replies:
    2
    Views:
    604
  3. saman1991
    Replies:
    1
    Views:
    629

Share This Page