The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please turn on SMTP Authentication in your mail client. (WHM 54)

Discussion in 'E-mail Discussions' started by JonTheWong, Jan 10, 2016.

  1. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Just wanted to see if anyone else was having the following problem; I migrated a few clients to WHM 54 from 11.52.2 using the Transfer tool. Everything was fine; until i noticed the following logs in exim.
    Code:
    2016-01-10 11:37:49 SMTP connection from [17.172.204.152]:43941 (TCP/IP connection count = 1)
    2016-01-10 11:38:09 H=st11p01im-asmtp002.me.com [17.172.204.152]:43941 Warning: Sender rate 1.0 / 1h
    2016-01-10 11:38:30 H=st11p01im-asmtp002.me.com [17.172.204.152]:43941 X=TLSv1.2:DHE-RSA-AES128-GCM-SHA256:128 CV=no F=<removed@icloud.com> rejected RCPT <removed@client.tld>: Please turn on SMTP Authentication in your mail client.  st11p01im-asmtp002.me.com [17.172.204.152]:43941 is not permitted to relay through this server without authentication.
    2016-01-10 11:38:30 H=st11p01im-asmtp002.me.com [17.172.204.152]:43941 Warning: "Detected session with all messages failed"
    2016-01-10 11:38:30 H=st11p01im-asmtp002.me.com [17.172.204.152]:43941 Warning: "Increment slow_fail_block Ratelimit - st11p01im-asmtp002.me.com [17.172.204.152]:43941 because of all messages failed"
    2016-01-10 11:38:30 SMTP connection from st11p01im-asmtp002.me.com [17.172.204.152]:43941 closed by QUIT
    
    Most topics on the issue are geared towards CLIENT side configuration issues; so i figured i post this incase anyone has had the same problem.

    The problem seems to be with Automatically Detect Configuration under "Edit DNS Zone"
    After importing the domain i noticed it was setting the Exchange as Remote and created the above error logs.

    Based on the setting it should automatically detect the server as local;

    an example domain would be example.com

    dig +trace example.com MX +short

    MX 0 caspar.example.com. from server 216.218.xxx.x in 22 ms.
    MX 2 mxus.example.com. from server 216.218.xxx.x in 22 ms.
    MX 1 mxca.example.com. from server 216.218.xxx.x in 22 ms.
    MX 3 mxeu.example.com. from server 216.218.xxx.x in 22 ms.

    caspar.example.com is the right server for local detection.

    I've tried using the /scripts/mailperms to regenerate the /etc/localdomains file, that didn't seem to fix the issue. All domains were setup in /etc/remotedomains.

    After setting the DNS to Local Mail Exchanger it was resolved.

    I have not summited a bug for this, since i didn't have a chance to replicate the issue.
     
    #1 JonTheWong, Jan 10, 2016
    Last edited by a moderator: Jan 10, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,786
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you elaborate on the MX records utilized in the DNS zones for these domain names? Are these standard MX records or are custom hostnames/servers utilized?

    Thank you.
     
  3. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    The MX records are as follow;

    cat /var/named/example.tld.db | grep mx

    example.tld. 86400 IN MX 0 caspar.example2.tld.
    example.tld. 86400 IN MX 1 mxca.example2.tld.
    example.tld. 86400 IN MX 2 mxus.example2.tld.
    example.tld. 86400 IN MX 3 mxeu.example2.tld.

    example2.tld is setup with all the right A records. E-Mail is flowing fine after i setup all newly transferred domains to LOCAL Exchange
     
  4. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    This seems to also effect SMX Plugin not being able to pull the domain list and generate a proper /etc/remotedomains list.
     
  5. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    /scripts/checkalldomainsmxs

    Is not seeing the right information, and seems to be the cause of the initial problem.

    Checking and setting clientdomain.tld ....
    info [checkalldomainsmxs] [checkmx] caspar.ourserver.tld was resolved using gethostbyname
    info [checkalldomainsmxs] [checkmx] mxca.ourserver.tld was resolved using gethostbyname
    info [checkalldomainsmxs] [checkmx] mxus.ourserver.tld was resolved using gethostbyname
    info [checkalldomainsmxs] [checkmx] mxeu.ourserver.tld was resolved using gethostbyname
    REMOTE MAIL EXCHANGER: This server will NOT serve as a mail exchanger for clientdomain.tld's mail.: This configuration has been automatically detected based on your mx entries.<br />....Done

    Pulled from clientdomain.tld.db
    clientdomain.tld. 3600 IN MX 0 caspar.ourserver.tld.
    clientdomain.tld. 3600 IN MX 1 mxca.ourserver.tld.
    clientdomain.tld. 3600 IN MX 2 mxus.ourserver.tld.
    clientdomain.tld. 3600 IN MX 3 mxeu.ourserver.tld.

    dig clientdomain.tld mx +short @8.8.8.8
    1 mxca.ourserver.tld.
    2 mxus.ourserver.tld.
    3 mxeu.ourserver.tld.
    0 caspar.ourserver.tld.


    This server (caspar) is using a remote DNS system thats in house; no special rules or local domains configured. Just a cache bind setup to serve the clusters.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,786
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Here's the message that's output when running the script you referenced:

    This suggests you should not utilize this utility if the DNS for the domain name is handled externally. However, the transfer itself should be able to detect if a MX record is local or remote. Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  7. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    The DNS is setup as follow;

    caspar is "master" sends to DNSOnly dnsca/us/eu but is NOT listed as an IP in the dns clusters and has port 53 closed.
    So the SOA for DNSCluster does not show caspar.

    Thats why the message could be failing since the zones are local but the SOA is remote

    caspar is listed in MX0 as shows above.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,786
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you let us know if you are able to reproduce the issue on cPanel version 54.0.15? CPANEL-3993 addresses an issue where transferring an account from cPanel version 11.52 or older results in "Remote Mail Exchanger" getting set for the "Mail Routing" configuration, when it should utilize "Automatically Detect Configuration".

    Thank you.
     
  9. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    Can't confirm as of yet; don't have any transfers to do. I'll try and update when it happens
     
Loading...

Share This Page