The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please turn on SMTP Authentication

Discussion in 'E-mail Discussions' started by s.isselmou, Jul 12, 2017.

  1. s.isselmou

    s.isselmou Member

    Joined:
    Jul 12, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Mauritania
    cPanel Access Level:
    Root Administrator
    We have a local server on which a web application is installed, this server is supposed to send mails from a mail whose SMTP is hosted at a hosting provider, but sends it fails.
    Initially, the server sends the following error message:
    550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)
    But we have disabled the "Require RFC-compliant HELO" option and we succeeded in sending emails but only to mails that belongs to the same domain.
    For other destinations (eg GMAIL) the sending fails, the error message has changed and the server now sends the following message:
    550-Please turn on SMTP Authentication in your mail client
    Then we added the ip address of our local server in the SPF of the SMTP server but it did not work.
    Thank you for helping us resolve this issue
     
  2. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Try disabling SMTP Tweak:

    WHM > SMTP Restrictions > Disable
     
  3. s.isselmou

    s.isselmou Member

    Joined:
    Jul 12, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Mauritania
    cPanel Access Level:
    Root Administrator
    Hello,
    First of all, thank you for your reply.
    If we disable this option, our server will be less secure?
    If this solution does not work, it is easy to return to the initial state? And how?

    Thank you in advance.

    Best regards
     
  4. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Yes its easy, just click Enable. This is to test to see if that's the cause.
     
  5. s.isselmou

    s.isselmou Member

    Joined:
    Jul 12, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Mauritania
    cPanel Access Level:
    Root Administrator
    I make your proposal but unfortunately nothing to change always the same problem
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,029
    Likes Received:
    1,277
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Can you confirm the script you are using to send email is using SMTP Authentication to send the email? For instance, have you created an email account through cPanel and then configured the email account username and password in the script's configuration file or setup page? Also, do you have any firewall management applications such as CSF installed on the server?

    Thank you.
     
  7. s.isselmou

    s.isselmou Member

    Joined:
    Jul 12, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Mauritania
    cPanel Access Level:
    Root Administrator
    After testing on the outlook client we noticed that the sending of emails works well if we use the configuration SSL (port 465), but it does not work when we use the parameters non-SSL (prot 25) Which is abnormal.
    Sending mail using the SMTP server with non-SSL settings is paramount for the operation of our application because it uses the default port 25.
    We have a VPS server that uses WHM / Cpanel.
    How to see on our server that the firewall is active or not
    thank you.
     
  8. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Go into WHM and scroll down to the bottom of the list on the left under Plugins it will say:

    "ConfigServer Security & Firewall"
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,029
    Likes Received:
    1,277
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You can disable the following option under the "Security" tab in "WHM >> Exim Configuration >> Basic Editor" if you want to allow non-SSL authentications:

    "Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server."

    Note that disabling this option will significantly decrease the security of the server by allowing the plaintext transmission of authentication credentials. Ideally, you would modify the script or consult with the developer so that it uses SSL when authenticating.

    Thank you.
     
  10. s.isselmou

    s.isselmou Member

    Joined:
    Jul 12, 2017
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Mauritania
    cPanel Access Level:
    Root Administrator
    Hello Michael
    We have disabled the option is it works, the problem has been solved infinitely thank you.
    also thanks Jcats.
     
    cPanelMichael likes this.
Loading...

Share This Page