Pls. help me with Update System Software.

foxdevil

Member
May 15, 2008
11
0
51
Hi, to day I try to update system software but I have following message:

Update System Software
Setting up Update Process
Setting up repositories
Method: Perl Expect
Fetching CPAN timestamp...Done
Testing connection speed...(this could take a while)...Done
Ping:147.478 Testing connection speed to ftp.cuhk.edu.hk using pureperl...(3104.95 bytes/s)...Done
Ping:133.880 Testing connection speed to cpan.mirror.choon.net using pureperl...(1409.65 bytes/s)...Done
Three usable mirrors located
Mirror Check passed for ftp.cuhk.edu.hk (/index.html)
Unknown config variable 'less'
commit: wrote '/usr/lib/perl5/5.8.5/CPAN/Config.pm'
CPAN: File::HomeDir loaded ok (v0.69)
CPAN: Storable loaded ok (v2.18)
Going to read /home/.cpan/Metadata
Database was generated on Wed, 14 May 2008 19:31:32 GMT
Devel::PPPort is up to date (3.13).
HTTP::Date is up to date (5.810).
Scalar::Util is up to date (1.19).
cPCPAN: Module (LWP) holdback (5.812 held back to 5.810)
MIME::Base64 is up to date (3.07).
Digest::MD5 is up to date (2.36).
URI is up to date (1.36).
Net::FTP is up to date (2.77).
HTML::Tagset is up to date (3.20).
HTML::Parser is up to date (3.56).
HTML::HeadParser is up to date (2.22).
LWP is up to date (5.810).
Crypt::SSLeay is up to date (0.57).
Digest::MD5 is up to date (2.36).
Digest::SHA1 is up to date (2.11).
Encode is up to date (2.25).
ExtUtils::Constant is up to date (0.16).
ExtUtils::ParseXS is up to date (2.19).
File::Touch is up to date (0.02).
Filesys::Df is up to date (0.92).
Filesys::Virtual is up to date (0.06).
Filter::Util::Call is up to date (1.07).
Getopt::Long is up to date (2.37).
cPCPAN: Module (Compress::Raw::Zlib) holdback (2.010 held back to 2.005)
Compress::Raw::Zlib is up to date (2.005).
Net::FTPSSL is up to date (0.04).
Net::SSL is up to date (2.84).
cPCPAN: Module (Net::SSLeay) holdback (1.32 held back to 1.30)
Net::SSLeay is up to date (1.30).
cPCPAN: Module (IO::Compress::Gzip) holdback (2.010 held back to 2.005)
IO::Compress::Gzip is up to date (2.005).
IO::Scalar is up to date (2.110).
IO::Socket::SSL is up to date (1.13).
IO::Stty is up to date (.02).
cPCPAN: Module (IO::Uncompress::Gunzip) holdback (2.010 held back to 2.005)
IO::Uncompress::Gunzip is up to date (2.005).
Lchown is up to date (1.00).
List::Util is up to date (1.19).
MD5 is up to date (2.03).
Net::AIM is up to date (1.22).
Net::DNS is up to date (0.63).
Net::OSCAR is up to date (1.925).
Storable is up to date (2.18).
Term::ReadKey is up to date (2.30).
Term::ReadLine::Perl is up to date (1.0302).
Time::HiRes is up to date (1.9715).
Tree::MultiNode is up to date (1.0.10).
Could not eval '
package ExtUtils::MakeMaker::_version;
no strict;
BEGIN { eval {
# Ensure any version() routine which might have leaked
# into this package has been deleted. Interferes with
# version->import()
undef *version;
require version;
"version"->import;
} }

local $VERSION;
$VERSION=undef;
do {
use version;our $VERSION = qv('0.0.15');
};
$VERSION;
' in /usr/lib/perl5/site_perl/5.8.5/Unix/PID.pm: Undefined subroutine &version::qv called at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/version.pm line 31, <$fh> line 5.
Could not eval '
package ExtUtils::MakeMaker::_version;
no strict;
BEGIN { eval {
# Ensure any version() routine which might have leaked
# into this package has been deleted. Interferes with
# version->import()
undef *version;
require version;
"version"->import;
} }

local $VERSION;
$VERSION=undef;
do {
use version;our $VERSION = qv('0.0.15');
};
$VERSION;
' in /usr/lib/perl5/site_perl/5.8.5/Unix/PID.pm: Undefined subroutine &version::qv called at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/version.pm line 31, <$fh> line 5.
Could not eval '
package ExtUtils::MakeMaker::_version;
no strict;
BEGIN { eval {
# Ensure any version() routine which might have leaked
# into this package has been deleted. Interferes with
# version->import()
undef *version;
require version;
"version"->import;
} }

local $VERSION;
$VERSION=undef;
do {
use version;our $VERSION = qv('0.0.15');
};
$VERSION;
' in /usr/lib/perl5/site_perl/5.8.5/Unix/PID.pm: Undefined subroutine &version::qv called at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/version.pm line 31, <$fh> line 5.
Running install for module 'Unix::PID'
Running make for D/DM/DMUEY/Unix-PID-0.0.15.tar.gz
Out of memory!
Tested 104, 104 ok, 0 failed.
GD installed ok

=====================

What is ... Out of memory..., what can I do?

and I try to install Perl v 5.8.8 by download from http://layer1.cpanel.net....
But I have problem after run install too.

Thanks Advance.
 

foxdevil

Member
May 15, 2008
11
0
51
Thanks for reply

Thanks very much for reply.

and I try to upgrade by read from e-mail ([email protected]<myserver.com>)

I use command: perl -MCPAN -e 'autobundle'
and download file from layer1.cpanel.net and use command ./install but I have error message (see attach file)

when reboot system the version (Perl) do not update.

How I can do update... :(
 

Attachments

foxdevil

Member
May 15, 2008
11
0
51
...

Yes, I did.
Here's a checklist of items that can help things go smoothly when upgrading to cPanel 11:



1) Make sure you're running Perl 5.8.8:

a) check perl -v to make sure it says 5.8.8

b) if you see 5.8.7 or something else, follow these steps:

1) wget http://layer1.cpanel.net/perl588installer.tar.gz
2) tar xfvz perl588installer.tar.gz
3) cd perl588installer
4) ./install
5) /usr/local/cpanel/bin/checkperlmodules
I do step-by-step from your link when I run ./install I have error message.
(my perl's version is 5.8.5 I want to update to 5.8.8)
 

foxdevil

Member
May 15, 2008
11
0
51
Pls. help me when install perl 5.8.8

Hello,
I try to update Perl from 5.8.5 to 5.8.8 but I have message and prompt File to Patch: (see attach file)

I don't know how can fix the problem, pls help me.
 

Attachments

foxdevil

Member
May 15, 2008
11
0
51
:confused: Sorry. I don't know what do you mean.
I have problem when I type ./install and have a message:
===============================
Can't find file to patch at input line 3
Perhamps you used the wrong -p or --strip option?
===============================

What is this....

I want to know how to install by do not have error. but you paste your link and I try to read more and more but it can't help me.

Any one can help me?
Not paste only link, can point me how i edit script before install or change any thing...
 

foxdevil

Member
May 15, 2008
11
0
51
Bingo!

:p I can do it!

I try to read install script, and download perl-5.8.8.tar.gz from CPAN.org and upload to my server later.

When I type ./install it passed not have an error message.

It possible from file incompleted download. (perl-5.8.8.tar.gz)

Thanks for read my problem and reply.
 

foxdevil

Member
May 15, 2008
11
0
51
Yeh!

:D I can do it!

I try to read install script, and download perl-5.8.8.tar.gz from CPAN.org and upload to my server later.

When I type ./install it passed not have an error message.

It possible from file incompleted download. (perl-5.8.8.tar.gz)

Thanks for read my problem and reply.