The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Plugin / cpsrvd-ssl error

Discussion in 'General Discussion' started by AndyM, Jul 13, 2010.

  1. AndyM

    AndyM Registered

    Joined:
    Mar 8, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Yesterday, my VPS got corrupted by a file system error at the hosts, and while they rebuilt cPanel, there is one thing still awry.

    When trying to load some plugin pages (Fantastico, Installatron and RV SItebuilder), I get the following error:

    Code:
    open3: exec of /usr/local/cpanel/whostmgr/docroot/cgi/addon_fantastico.cgi failed at cpsrvd-ssl line 5970
    Internal Error: "GET /cgi/addon_fantastico.cgi HTTP/1.1" open3: exec of /usr/local/cpanel/whostmgr/docroot/cgi/addon_fantastico.cgi failed at cpsrvd-ssl line 5970
    Firefox gives:
    Code:
    SSL received a record with an incorrect Message Authentication Code.
    
    (Error code: ssl_error_bad_mac_read)
    I've tried reinstalling Fantastico, resetting cPanel/WHM's SSL cert, etc., ran /scripts/upcp --force.

    cPanel 11.25.0-R46156 - WHM 11.25.0 - X 3.9
    CENTOS 5.5 i686 virtuozzo on xxxx

    Any ideas?
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Check the permissions of /usr/local/cpanel/whostmgr/docroot/cgi/addon_fantastico.cgi, should be 755 .
     
  3. AndyM

    AndyM Registered

    Joined:
    Mar 8, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Tried that and checked the owner, and the fantastico subdir.

    I think it's an SSL error somewhere, but I'm not sure where...
     
  4. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    While cPanel won't be able to troubleshoot the third-party plugin issue, if you are receiving an SSL error in a browser for something, you might consider opening a ticket with cPanel in WHM > Support Center > Contact cPanel area.

    I'm not entirely certain this is due to an SSL error, though. The error isn't very commonplace and the only hits I found were for AwStats having a similar error.

    For one idea, could you try running this command?

    Code:
    /scripts/makecpphp
    I want to see if it might be due to the internal cPanel PHP not being built properly when the machine was restored. I highly doubt it would have anything to do with this since it's a cpsrvd error, but you never know and I didn't want to rule it out.
     
Loading...

Share This Page