The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Plus sign in default address is not accepted

Discussion in 'General Discussion' started by lvinchat, Apr 2, 2006.

  1. lvinchat

    lvinchat Registered

    Joined:
    Apr 2, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am attempting to set up a catch-all to deliver to an external/non-local domain account. The external account contains a plus sign which CPanel strips out when I configure external+account@externaldomain.com as the catchall. I've had reasonable success in the past with creating a forwarder for messages to badaddress@localdomain.com pointing to the external account, then configuring the catch-all address as badaddress@localdomain.com. Unfortunately, after my hosting providers recent CPanel upgrade this appears to have stopped working and I'm no longer getting the wonderful array of spam sent to non-existent addresses @localdomain.com at the external account. Not that I mind if I don't get my offers to make millions from Nigerian 419 scams, but it does hamper my ability to set up one-off accounts that could be published to the web or traded/sold by unscrupulous companies.
    Is it possible with user-level access to get this to work again, either with forwarders or with a plus sign in the default address? If not, is there something I can ask my provider to enable/change to allow this to work again?
    TIA
    Landis
     
  2. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    strange that it doesn't allow the plus...

    you should be able to do this:

    create forwarder from ext@yourdomain.com -> your+email@otherdomain.com
    set catchall to ext@yourdomain.com

    All unrouted mail will be sent to ext@yourdomain.com, which will then be forwarded to the offsite address with the + in it.

    "ext" is just an example, you could use any name in place of it.
     
  3. lvinchat

    lvinchat Registered

    Joined:
    Apr 2, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    It appears to be working properly configured with a catchall on the local domain forwarding to the external domain. I had neglected to check the account with an account on an external domain and didn't consider that messages sent within the domain could be encountering problems. At least some external messages appear to be going through now, although there are still a couple of external domains that seem to be having some problems, but that could be filters. Either way, this does appear to be working properly now. Thanks!
    LV
     
Loading...

Share This Page