SOLVED Point 2 subdomains to the same folder

patricknn

Member
Oct 12, 2011
6
1
51
cPanel Access Level
Root Administrator
Hi guys

I'm trying to point 2 subdomains to the same document root but I'm not being able not even to add the domain to this specific account on it's Cpanel.

The first thing that I'm trying to do is to add a new Domain to this account. Here it is the steps:
1 - I go to the Cpanel of the domain xxxx.com, Domains menu and I try to add a new domain yyyy.com.
2- I receive this message:

Error: (XID vbt9p4) Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.

Once this does not work I went to Cpanel WHM, Menu option Add DNS Zone I fill the IPv4 address as the same xxxx.com account IPv4 address, fill the new domain yyyy.com, associate with the xxxx.com account and the zone is created successfully.
After that I go back to the xxxx.com Cpanel, subdomains menu, I type the new subdomain that is "ticket", select the new domain that is yyyy.com, type the same Document root that is "ticket", click in create and then I receive another error message:

There was a problem creating the sub-domain:
(XID z8nm9w) (XID bqh8rj) The domain “yyyy.com” does not exist in the userdata for the user “xxxx”. at /usr/local/cpanel/Cpanel/Admin/Modules/Cpanel/subdomain.pm line 176.

Any ideia what can I do to fix this?
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
Error: (XID vbt9p4) Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.
There are two things you can do if the domain is remote (which is why you're receiving this error)

1. The best and most optimal is add the domain's IP address to /etc/ips.remotedns as suggested or WHM>>IP Functions>>Configure Remote Service IP's which is the same thing just the UI for it.

or

2. You can go to WHM>>Server Configuration>>Tweak Settings and enable "Allow Remote Domains"