POP/IMAP/Webmail login problems

drose25

Well-Known Member
Apr 3, 2002
50
0
306
I woke up this morning to find that no one can login to check email...whether they attempt it via POP, IMAP, or try to login via webmail.

Maillog shows this error:

Aug 21 10:52:30 max pop3d: LOGIN FAILED,[email protected]******.com, ip=[::ffff:70.251.80.90]
Aug 21 10:52:30 max pop3d: authentication error: Input/output error

Trying to login in via webmail, you can login to the first page, where you select between Horde/Squirrelmail/etc, but trying to login to Horde generates this error:

Login failed because your username or password was entered incorrectly.

I've tried restarting the POP and IMAP services, with no luck. Also ran
/scripts/courierup --force
without any luck either.

Any suggestions?
 

caeos

Well-Known Member
Jul 18, 2007
79
0
56
UK
This is apparently NOT an exim error but a courier error,
it has disabled my email for a week now.
pop/imap wont work, but email forwarding will.

did you also get an exim update email?
 

drose25

Well-Known Member
Apr 3, 2002
50
0
306
Enabling debug output in authdaemond gives the following insight into the generic input/output error, if anyone can make sense of it.

Aug 21 15:21:38 max authdaemond: received auth request, service=pop3, authtype=login
Aug 21 15:21:38 max authdaemond: authpipe: trying this module
Aug 21 15:21:38 max authdaemond: closing pipe
Aug 21 15:21:38 max authdaemond: forking new one
Aug 21 15:21:38 max authdaemond: attempting to fork
Aug 21 15:21:38 max authdaemond: executing /etc/authlib/authProg
Aug 21 15:21:38 max authdaemond: Pipe auth. started Pipe-program (pid 13811)
Aug 21 15:21:38 max authdaemond: new pipe has in: 8, out: 7
Aug 21 15:21:38 max authdaemond: authpipe: TEMPFAIL - no more modules will be tried
 

MaestriaNick

Well-Known Member
Aug 6, 2008
159
3
68
did you try a /scripts/courierup –force to reinstall it ?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Check whether /var/cpanel/cpanel.config.lock exists. If the lock file does exist, remove it and test a Courier login.
 

drose25

Well-Known Member
Apr 3, 2002
50
0
306
I didn't find a real fix for this issue. For me, downgrading from Current to Release fixed the issue. I haven't tried upgrading back to Current to see if the problem re-appears.

One poster on WHT reported they solved the problem by running upcp, so it may be that just a forced re-install of Cpanel will resolve the issue. Your mileage may vary.
 

caeos

Well-Known Member
Jul 18, 2007
79
0
56
UK
this and http://forums.cpanel.net/showthread.php?t=90425
seem to be referencing the same issue.

IMAP down, all courier and SQL running..

i was on current but downgraded to
WHM 11.23.2 cPanel 11.23.4-S26138 and am still experiencing the issues.
I upgraded to latest stable and it was working till this morning then went off line.

the lock file is not in place, all mailboxes have quotas..
now stuck
 

paulkoan

Well-Known Member
Nov 24, 2006
80
0
156
This is now happening on one of our servers too. The same input output errors, on both pop3 and imap. But many authentication attempts work successfully. A locking issue may be the cause of it, but cpanel.config.lock is not present.

The potential solution above recreates a horde sql table, but I cannot see how that can cause imap and pop3 authentications to fail.

Did anyone get to the bottom of this?

Cheers,

Paul
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,481
35
208
cPanel Access Level
DataCenter Provider
This is now happening on one of our servers too. The same input output errors, on both pop3 and imap. But many authentication attempts work successfully. A locking issue may be the cause of it, but cpanel.config.lock is not present.

The potential solution above recreates a horde sql table, but I cannot see how that can cause imap and pop3 authentications to fail.

Did anyone get to the bottom of this?

Cheers,

Paul
If you have already restarted courier, you might want to consider switching to dovecot. Otherwise we can investigate if you open a ticket @ https://tickets.cpanel.net/submit/
 

niladam

Member
Aug 29, 2007
13
0
51
Romania
cPanel Access Level
Root Administrator
solution

After further investigating this i think i may have found a dirty fix. The fix would be to have the user's email password changed to something WITHOUT spaces.

I fixed this for a client of mine. I think this should be put into cpanel's add new email account so that people know they're doing this on their own.

So, a password using SPACES can cause that error. Tried everything, but NOTHING, besides the PASSWORD CHANGE to something that had NO SPACES fixed it.

Hope it helps :)
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
After further investigating this i think i may have found a dirty fix. The fix would be to have the user's email password changed to something WITHOUT spaces.

I fixed this for a client of mine. I think this should be put into cpanel's add new email account so that people know they're doing this on their own.

So, a password using SPACES can cause that error. Tried everything, but NOTHING, besides the PASSWORD CHANGE to something that had NO SPACES fixed it.

Hope it helps :)
In cPanel 11.25 we updated our password validation to prevent spaces in passwords. All passwords.