The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pop not starting.

Discussion in 'General Discussion' started by david510, Jun 26, 2005.

  1. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Hello All,

    In one of my serevr after a reboot. The POP serevr is not getting started. Everytime I restart cpanel I get the following in the shell. What could be the problem.

    Stopping cPanel services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [ OK ]
    Stopping Melange Chat services: [ OK ]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner

    Starting SMTP Tweak: [ OK ]
    Starting eximstats: [ OK ]
    Starting cPanel services: [ OK ]
    Starting cPanel Log services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services: [ OK ]
    Starting Melange Chat services: [ OK ]
    Starting cPanel ssl services: [ OK ]
    Starting mailman services: Starting Mailman's master qrunner.
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    I don't see any problem. InterChange is probably not enabled on your server and that's why it returns "FAILED" message. Any error messages related to POP in the log file(s)?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've actually seen this on occasion where cppop doesn't start after a reboot. Either restart cPanel yourself as you have done or run:

    /scripts/restartsrv_cppop

    You could even put that line into /etc/rc.d/rc.local if you wanted to.
     
  4. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Hello Chirpy and Andy,

    Thanks for your suggestions. After I restarted cpanel, pop was not working.

    But I checked /var/log/messages and found this.

    /var/cpanel/cpanel.config
    extracpus=10
    change this value to 0

    I did so and the pop started working. Then I chaged this value back to 10 and restarted cpanel. Now pop is working fine.

    Does this make any sense? Is that because of this pop was not starting?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would imagine that was just a coincidence, I've seen it where you have to restart cppop (or cpanel) 2 or 3 times after a reboot to get cppop to stay up.
     
  6. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    That's true. Sometimes you need to restart a service more than once.
     
Loading...

Share This Page