POP3 Gmail marks emails as read

madnoob2

Active Member
Apr 18, 2017
35
0
6
Austria
cPanel Access Level
Root Administrator
Hey folks,

I have an e-mail account on cPanel which is connected to GMAIL's POP3 connector. Every time POP3 gets the e-mails from the account, it marks them as read in webmail.
Is it possible to prevent this from happening? I know POP3 is very limited, but maybe something on exim's side can stop them from being read?
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @madnoob2,

Can you browse to Gmail >> Settings >> Accounts and Import and then click on Edit Info next to your POP3 account to verify if the Leave a copy of retrieved message on the server option is enabled? If so, it should not mark the email as read in Webmail.

Thank you.
 

madnoob2

Active Member
Apr 18, 2017
35
0
6
Austria
cPanel Access Level
Root Administrator
Hello @madnoob2,

Can you browse to Gmail >> Settings >> Accounts and Import and then click on Edit Info next to your POP3 account to verify if the Leave a copy of retrieved message on the server option is enabled? If so, it should not mark the email as read in Webmail.

Thank you.
Hi Michael,

the option is enabled already. Something else is the issue... Previous host that we migrated the account from did not have this issue.
 

rpvw

Well-Known Member
Jul 18, 2013
1,088
446
113
UK
cPanel Access Level
Root Administrator
Check out the changes that Gmail have made to the POP download process at Read Gmail messages on other email clients using POP - Gmail Help with particular reference to the I want to download emails on multiple email clients section.

Also ensure you have set up the 2. When messages are accessed with POP setting in your Gmail Settings to an appropriate option for what you want to occur.


If you are doing it the other way (eg Gmail is polling your cPanel email account using POP3) make sure that the Check email from other accounts: option for the account is set to leave message on server (see Check emails from other accounts - Computer - Gmail Help for full details), or maybe consider using a forwarder from cPanel to your Gmail account.
 
Last edited:
  • Like
Reactions: cPanelMichael