The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

POP3 Login Issues - Intermittent

Discussion in 'E-mail Discussions' started by jwtech, Oct 15, 2007.

  1. jwtech

    jwtech Registered

    Joined:
    Oct 13, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Login Issues: POP3 - Authentication error: No such file or directory

    G'day guys,

    Recently went over to a box running cpanel and have been transfering our clients across to this server. I got a phone call this morning and all mail users couldn't log in (including myself - Thunderbird gave me a nice error explaining the mail server was unavailable at this time whilst most clients use outlook or similar so just keep getting asked for passwords...).

    After a quick bit of investigation I notice I keep receiving errors in the maillog like this...

    Code:
    Oct 16 08:29:54 SERVER pop3d-ssl: authdaemon: s_connect() failed: No such file or directory
    Oct 16 08:29:54 SERVER pop3d-ssl: LOGIN FAILED, user=USER@DOMAIN.net, ip=[::ffff:VALIDIP]
    Oct 16 08:29:54 SERVER pop3d-ssl: authentication error: No such file or directory
    Oct 16 08:30:13 SERVER pop3d-ssl: authdaemon: s_connect() failed: No such file or directory
    Oct 16 08:30:13 SERVER pop3d-ssl: LOGIN FAILED, user=USER@DOMAIN.net, ip=[::ffff:VALIDIP]
    Oct 16 08:30:13 SERVER pop3d-ssl: authentication error: No such file or directory
    Oct 16 08:31:46 SERVER pop3d: authdaemon: s_connect() failed: No such file or directory
    Oct 16 08:31:46 SERVER pop3d: LOGIN FAILED, user=USER@DOMAIN.net.au, ip=[::ffff:VALIDIP]
    Oct 16 08:31:46 SERVER pop3d: authentication error: No such file or directory
    
    Restarting the pop server seems to solve it temporarily (day or so) - this is not the first time it has done this but the first time I investigated it a bit further.

    A fair bit of googleing this error message results in not a great deal.

    Any assistance would be appreciated guys,
    James.
     
    #1 jwtech, Oct 15, 2007
    Last edited: Oct 16, 2007
  2. totaltec

    totaltec Registered

    Joined:
    Jan 10, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    your not alone

    it seems my server failed at 4.00 am just after the upcp script fires, but im set to manaul updates so it just seems to run the script and then finish,

    once the upcp is done i get this on pop3 log

    authentication error: No such file or directory

    i had no problems at all with this untill i updated last friday
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You may wish to submit a support request regarding this issue.
     
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    wondering if it could be a case problem with those usernames?
     
  5. barc0001

    barc0001 Registered

    Joined:
    Oct 16, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I had a similar problem, restart fixed it too.

    We'll see if it stays working overnight.
     
  6. ChrisHardie

    ChrisHardie Registered

    Joined:
    May 14, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    We upgraded to 11.15.0-R17665 today and as a part of that process, apparently the courier-authdaemon process did not get successfully restarted following the upgrade. As a result, all POP and mail-related logins were failing. It was fixed for me by running:

    # /usr/local/etc/rc.d/courier-authdaemond start

    (We're on FreeBSD, your pathname may vary.)

    cPanel folks, this may be something that needs addressing in the installer/upgrader process.

    Chris
     
  7. ee99ee

    ee99ee Well-Known Member

    Joined:
    Aug 15, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    This happenend to us last night. This resolved it for us (FreeBSD):

    # /usr/local/etc/rc.d/courier-authdaemond.sh start

    Thanks ChrisHardie!

    -Chris
     
Loading...

Share This Page