POP3 Login Issues - Intermittent

jwtech

Registered
Oct 13, 2007
2
0
51
Login Issues: POP3 - Authentication error: No such file or directory

G'day guys,

Recently went over to a box running cpanel and have been transfering our clients across to this server. I got a phone call this morning and all mail users couldn't log in (including myself - Thunderbird gave me a nice error explaining the mail server was unavailable at this time whilst most clients use outlook or similar so just keep getting asked for passwords...).

After a quick bit of investigation I notice I keep receiving errors in the maillog like this...

Code:
Oct 16 08:29:54 SERVER pop3d-ssl: authdaemon: s_connect() failed: No such file or directory
Oct 16 08:29:54 SERVER pop3d-ssl: LOGIN FAILED, [email protected], ip=[::ffff:VALIDIP]
Oct 16 08:29:54 SERVER pop3d-ssl: authentication error: No such file or directory
Oct 16 08:30:13 SERVER pop3d-ssl: authdaemon: s_connect() failed: No such file or directory
Oct 16 08:30:13 SERVER pop3d-ssl: LOGIN FAILED, [email protected], ip=[::ffff:VALIDIP]
Oct 16 08:30:13 SERVER pop3d-ssl: authentication error: No such file or directory
Oct 16 08:31:46 SERVER pop3d: authdaemon: s_connect() failed: No such file or directory
Oct 16 08:31:46 SERVER pop3d: LOGIN FAILED, [email protected], ip=[::ffff:VALIDIP]
Oct 16 08:31:46 SERVER pop3d: authentication error: No such file or directory
Restarting the pop server seems to solve it temporarily (day or so) - this is not the first time it has done this but the first time I investigated it a bit further.

A fair bit of googleing this error message results in not a great deal.

Any assistance would be appreciated guys,
James.
 
Last edited:

totaltec

Registered
Jan 10, 2005
4
0
151
your not alone

it seems my server failed at 4.00 am just after the upcp script fires, but im set to manaul updates so it just seems to run the script and then finish,

once the upcp is done i get this on pop3 log

authentication error: No such file or directory

i had no problems at all with this untill i updated last friday
 

rpmws

Well-Known Member
Aug 14, 2001
1,802
9
318
back woods of NC, USA
wondering if it could be a case problem with those usernames?
 

barc0001

Registered
Oct 16, 2007
3
0
51
I had a similar problem, restart fixed it too.

We'll see if it stays working overnight.
 

ChrisHardie

Registered
May 14, 2007
4
0
151
We upgraded to 11.15.0-R17665 today and as a part of that process, apparently the courier-authdaemon process did not get successfully restarted following the upgrade. As a result, all POP and mail-related logins were failing. It was fixed for me by running:

# /usr/local/etc/rc.d/courier-authdaemond start

(We're on FreeBSD, your pathname may vary.)

cPanel folks, this may be something that needs addressing in the installer/upgrader process.

Chris
 

ee99ee

Well-Known Member
Aug 15, 2003
70
0
156
This happenend to us last night. This resolved it for us (FreeBSD):

# /usr/local/etc/rc.d/courier-authdaemond.sh start

Thanks ChrisHardie!

-Chris