The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

POP3 Server Hanging on Certain Messages

Discussion in 'E-mail Discussions' started by keithc, Jul 25, 2007.

  1. keithc

    keithc Member

    Joined:
    Jun 5, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I've noticed as of Monday morning, that certain messages appear to cause the pop3 server to hang. For instance, I'll start downloading new email messages and it will end up stopping at the same point. Yesterday, it would stop at the 83rd message but today it was around message 10 (I think).

    My mailbox only has about 10MB of email in it with roughly 100 messages. Doing an strace on the my pop3 process didn't show anything out of the ordinary and also I couldn't find anything in the tcpdump.

    If I let Outlook (even tried Outlook Express with the same issue) sit for a little while, the messages eventually download or I can go into Webmail (or IMAP) and delete the message that is causing the problem and the send/receive will complete properly.

    Just wanted to see if anyone else had a similar issue. It's only happening on a few mailboxes at this point including my personal mailbox. Haven't heard too many other people complain.

    We're running Courier-Imap with pop3 service and our mailboxes are in MailDir format.

    Here is the relevant Cpanel server information

    WHM 11.2.0 cPanel 11.6.1-C15328
    CENTOS Enterprise 4.5 x86_64 - WHM X v3.1.0

    Here are the courier RPMs that are installed

    courier-imap-4.1.2-3cp
    courier-authlib-0.59.2-1cp
    courier-authlib-pipe-0.59.2-1cp
    courier-authlib-devel-0.59.2-1cp

    I see that the courierup script was updated on July 6th. Was thinking of trying a forced reinstall/update to see if this helps. Does anyone know whether or not courier-imap-4.1.2-3cp is the latest version of IMAP for Cpanel?

    Thanks,

    Keith
     
  2. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    You sure this isn't your internet connection being flakey?
     
  3. keithc

    keithc Member

    Joined:
    Jun 5, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the suggestion but I don't believe so. I tried it from various locations. Only seems to occur when my mailbox has anything over 10MB of email in it. Didn't happen today so maybe it fixed itself.

    Keith
     
  4. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    We have seen this problem for years, even prior to cpanel and exim. I really believe this is an issue with the CLIENT and not the SERVER.

    We have had countless calls from people telling us "the server is hung" on an email, but it will serve it via webmail without issue. Sometimes a customer tells us they are getting the same emails over and over again, each time they login. However we only see one copy in the email box/folder of the user. When these things happen we usually have to tell the customer to manually delete the email via webmail or try another email client. If they are getting this from spammers we will put filters in that customer to stop them from getting the garbage in the first place.

    Recently we had this with one user and we went into the mbox to see it and the format of the header was screwy, not following normal formats which probably caused some kind of parsing/processing issue with the email client.

    Its possible the server could be hanging on sending, but I think its more likely that the client cannot handle the header of a message and its almost always someone using outlook or outlook express. We used the simple program "popcorn" to download email that was "hanging the server" when using outlook express as the client and it worked fine.

    Maybe some of the above will help.
     
    #4 nyjimbo, Jul 26, 2007
    Last edited: Jul 26, 2007
Loading...

Share This Page