The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pop3ad not authenticating

Discussion in 'General Discussion' started by shiv, Jul 29, 2005.

  1. shiv

    shiv Member

    Joined:
    Jul 26, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bangalore
    Hi,

    I'm unable to check mails on my server.

    Here is the error found in /var/log/messages

    Jul 29 12:27:02 server xinetd[21292]: START: pop3 pid=19517 from=127.0.0.1
    Jul 29 12:27:02 server popa3d[19517]: Didn't attempt authentication
    Jul 29 12:27:02 server xinetd[21292]: EXIT: pop3 pid=19517 duration=0(sec)

    and when I send mail here is what I get

    Jul 29 12:31:48 server xinetd[21292]: START: pop3 pid=23749 from=202.56.253.42
    Jul 29 12:32:12 server popa3d(pam_unix)[23749]: check pass; user unknown
    Jul 29 12:32:12 server popa3d(pam_unix)[23749]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
    Jul 29 12:32:15 server popa3d[23749]: Authentication failed for UNKNOWN USER from 202.56.253.42
    Jul 29 12:32:15 server xinetd[21292]: EXIT: pop3 pid=23749 duration=27(sec)

    can any one help me with this please.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    There's no such daemon called popa3d on a cPanel server. You should edit the xinetd config file (hint: look in /etc/xinetd.d) and set disable to yes and restart xinetd then restart cPanel to get cppop working.
     
  3. rviradia

    rviradia Well-Known Member

    Joined:
    Jul 25, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    vi /etc/xinetd.d/popa3d

    change to "disable = yes"

    service xinetd restart
    /scripts/restartsrv_cppop
     
  4. skyhorse

    skyhorse Active Member

    Joined:
    Aug 18, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    There is a popa3d deamon in cpanel, I have it running.

    But it isn't working eheh

    I tried the /scripts/restartsrv_cppop but it says:

    Waiting to bind to port 110 (Address already in use)....
    Waiting to bind to port 110 (Address already in use)....

    forever...

    I will try to close the popa3d deamon down (i dunno how though)

    cheers,

    sky
     
  5. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    are you using cppop or did you convert to maildir? if you recently converted it takes a while and you will wind up with pop3 login failures.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Both myself and rviradia have told you how. popa3d is not part of cPanel, but is part of your original OS installation that has been left enabled by mistake by whoever built your server intially.
     
  7. raikd

    raikd Member

    Joined:
    Jun 25, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hey Chirpy..

    I too had the same again error again even after enabling the files in /etc/xinetd.d/ . But it was actually the xinetd service listening to the default pop port 110. I jus killed the xinetd PID and then ran /scripts/restartsrv_cppop which worked as kool as ice ,, :D
     
  8. duplu

    duplu Registered

    Joined:
    Nov 17, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for this, I had the popa3d service running on my system. Edited the file in xinetd.d, rebooted and now it's all fixed :)
     
Loading...
Similar Threads - pop3ad authenticating
  1. Deputy963
    Replies:
    4
    Views:
    225

Share This Page