The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pop3d-ssl not starting

Discussion in 'E-mail Discussions' started by ghstber, Oct 12, 2007.

  1. ghstber

    ghstber Member

    Joined:
    Oct 7, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Several users complained of not being able to make a POP3 connection via port 995 to one of our servers. After looking, it appears that courier-imap isn't starting the pop3d-ssl daemon. I've confirmed this through both a 'lsof -i:995' and telnetting to the server on port 995.

    I've checked over the configuration files in /usr/lib/courier-imap/etc/ and everything looks right. I've ran a /scripts/courierup --force and a /scripts/upcp --force as well. Both of these did not help the situation.

    Any ideas?
     
  2. tprice42

    tprice42 Active Member

    Joined:
    Sep 10, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Check in WHM under 'Manage Service SSL Certificates' and make sure that both pop3 and imap ssl daemons have certificates installed.

    Also check in WHM under 'Courier Configuration' and make sure that there are sane values in there.

    Finally depending on your linux / unix distro you may need to enable the service for loading at bootup, i know in freebsd you have to add:

    courier_authdaemond_enable=YES
    courier_imap_imapd_ssl_enable=YES
    courier_imap_imapd_enable=YES
    courier_imap_pop3d_ssl_enable=YES
    courier_imap_pop3d_enable=YES

    to /etc/rc.conf

    What OS are you running in any case?
     
  3. ghstber

    ghstber Member

    Joined:
    Oct 7, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I had already ensured that rc.conf was set up correctly, and also ensured that the SSL certificates were all set up correctly as well. Apparently, a colleague of mine asserted that some of the values in the Courier Configuration were not sane despite my ensuring previously that they were. This solved the issue.

    Thanks for the help!
     
Loading...

Share This Page