Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Possible bug. Can you someone please test? (Mail send limit shows "0")

Discussion in 'E-mail Discussion' started by electric, Dec 24, 2012.

  1. electric

    electric Well-Known Member

    Joined:
    Nov 5, 2001
    Messages:
    731
    Likes Received:
    3
    Trophy Points:
    318
    Hello,

    I am trying to determine if this is a bug or a misconfiguration I have made somewhere. Can anyone test this and confirm?

    Basically, the problem is that the "Maximum Hourly Email by Domain Relayed" and "Maximum percentage of failed or deferred messages a domain may send per hour" values show "0" in certain setups.

    1. Create a new reseller user and set ACL feature list so that they do NOT have the following items enabled:

    Package Access
    - Allow the reseller to use all global packages (global packages are any packages without a "_" in them)

    Packages Creation
    - Allow Creation of Packages with non-default Email Limits

    Account Management
    - Account Modification (warning: this will allow circumvention of account creation limits, give shell access unless explicitly disallowed, dedicated ips, etc)

    2. Now login to WHM as the new reseller and create (or edit) a package.

    You will see the "Maximum Hourly Email by Domain Relayed" and "Maximum percentage of failed or deferred messages a domain may send per hour" can't be modified (as expected), but have "0" values.

    The bug is that these two values should show whatever is set as the server defaults in the "Tweak Settings" screen.

    Can anyone confirm?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. electric

    electric Well-Known Member

    Joined:
    Nov 5, 2001
    Messages:
    731
    Likes Received:
    3
    Trophy Points:
    318
    Re: Possible bug. Can you someone please test? (Mail send limit shows "0"

    Bump. Anyone?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,479
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Re: Possible bug. Can you someone please test? (Mail send limit shows "0"

    I set both of those settings in Tweak Settings to 22. On Edit Package and Create Package, they show a 0, not a 22. On modify an Account screen the 22 shows up for both.

    You might want to open a defect ticket on this one:
    http://go.cpanel.net/bugs
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice