Possible bug with dedicated IP in Package Manager in WHM 11.34

Metro2

Well-Known Member
May 24, 2006
489
54
178
USA
cPanel Access Level
Root Administrator
I haven't submitted this as a bug report yet because I'm not entirely sure that it is one, but it looks to be.

After just recently upgrading from 11.32 to 11.34 (release) I've discovered a problem in the UI (which also affects package files).

In WHM > Packages > Edit A Package:

If I edit an existing package that is set with the Dedicated IP option enabled / checked, then Save Changes, then go back to edit it again; the Dedicated IP option becomes grayed-out and can't be changed.

In some cases it even removes the check mark next to the Dedicated IP option and I can't put it back!

So, I double-checked the package files in /var/cpanel/packages and sure enough - the packages that previously had "IP=y" now have "IP=n" after being edited.

I'm able to manually edit the package files and change it back to IP=y , and the check mark is back in WHM > Packages > Edit A Package , but it's still grayed out and cannot be changed via WHM UI.

I also checked to see if it made a difference if there is a space in the package name or not. No difference. For example - happens whether the package is named "Business Plan" or "BusinessPlan".

I don't recall this being normal behavior and I think it's a new bug but of course I could be wrong so thought it was best to check in with you all here before submitting a Bug Report.

In case environment matters:
cPanel 11.34.0.6
RHEL 5 64 bit
Apache 2.2.23
PHP 5.3.18
mySQL 5.5.27
boxes are low load and plenty of power

Thoughts?
 

Metro2

Well-Known Member
May 24, 2006
489
54
178
USA
cPanel Access Level
Root Administrator
One other minor bug I just noticed in the new Package Manager, somewhat related to the initial topic, this one is purely aesthetic / visual...

If you create a new package or edit a new package and set (for example):

Maximum Hourly Email by Domain Relayed - 600
Maximum percentage of failed or deferred messages a domain may send per hour - 70

And click Save

You you get this response:

Changing "Maximum Hourly Email by Domain Relayed" from unlimited to 600
Changing "Maximum percentage of failed or deferred messages a domain may send per hour" from unlimited to 600


As you can see, it tells you the wrong figure for the max percentage failed/deferred setting.

However, the bug is only in the UI. If you check the package file in /var/cpanel/packages it shows the correct setting, in this case:
MAX_DEFER_FAIL_PERCENTAGE=70
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
From your description it sounds like you are using a customized WHM theme. With a stock setup of cPanel & WHM, following your steps the UI doesn't inform me of the following:

Changing "Maximum Hourly Email by Domain Relayed" from unlimited to 600
Changing "Maximum percentage of failed or deferred messages a domain may send per hour" from unlimited to 600

I simply get a progress bar, and a Success! popup at the end.

The changing IP attribute (IP=y -> IP=n) I can reproduce in 11.32. I have filed a bug on this (case 62054).
 

Metro2

Well-Known Member
May 24, 2006
489
54
178
USA
cPanel Access Level
Root Administrator
Thanks for the reply cpanelkenneth, I appreciate it.

To clarify - I am definitely NOT using a customized WHM Theme.

Stock WHM theme (x) and stock cPanel (x3) that the servers come with.

Thanks for starting a case on the more important bug (IP attribute bug changing IP=y to IP=n and graying it out after editing a package). That's obviously much more important, but the minor aesthetic issue I brought up is also unnerving when you see it.
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
Attached is what I get when saving packages. It doesn't match at all what you described, which is why I suggested a customized WHM theme.

Which browser are you using? I've tried Chrome and FireFox.

Screen Shot 2012-11-02 at 9.33.59 AM.png
 

Metro2

Well-Known Member
May 24, 2006
489
54
178
USA
cPanel Access Level
Root Administrator
I use IE 9 and FF 16 and latest Chrome (depending on the need at the moment) so I can't recall exactly which browser I was using at that moment, but I do know this:

I don't always get the messages:

Changing "Maximum Hourly Email by Domain Relayed" from unlimited to 600
Changing "Maximum percentage of failed or deferred messages a domain may send per hour" from unlimited to 600

Sometimes I just get exactly what is in your screenshot.

In fact, every test edit I've done since the first several I did just before posting that, since then have all given me exactly what's in your screenshot. (the progress bar and the "Success!").

In any case, some strange things going on with the package manager and the IP function option is the bigger concern / pain in the but to have to go through and fix manually in every Dedicated IP package on every server. Thanks for starting the case on that bug!
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
Coming up on one year and still can't change the dedicated IP attribute on an existing package. (11.38.2.7 now)

Any chance this is being fixed?
What I reported, and what was fixed, was the unintentional changing of the IP attribute.

The (very) long standing behavior with account plans (nee packages) is the Dedicated IP attribute can only be determined when creating a new package. Am I understanding correctly that you desire to modify this attribute, the same as all the other plan attributes?

Please keep in mind that modifying a plan will result in accounts in turn being modified. Are you comfortable with upgrading all associated accounts to have dedicated IP addresses?