possible problem with fedora core 4 & exim

[email protected]

Well-Known Member
Jul 9, 2005
78
0
156
Belgium
hi people,

I'm testing this for several days now and it seems the cpanel / whm updating script (upcp) is causing a problem on my fedora core 4 server.

description
The upcp script wants to update the exim mail transfer agent (MTA) to the rpm package for codera core 4 (ending in FC4) when this succeeds your e-mail server no longer works and you are unable to receive nor send any e-mail

workaround
the /scripts/eximup seems to fix this problem also make sure your domains are listed in "/etc/localdomains" that seems like fixing the problem however i would like to have a better solution then having to change that all the time(and loose some e-mails cause i do sleep at night)

anyone noticed the same problem ? is it possible to "exclude" a single package from the update script telling the script not to update that package ?
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
32
473
Go on, have a guess
That's a problem with your OS installation. You should not have installed exim when the OS was built. Now that it has been installed, you should exclude exim in your yum.conf file.
 

[email protected]

Well-Known Member
Jul 9, 2005
78
0
156
Belgium
chirpy said:
That's a problem with your OS installation. You should not have installed exim when the OS was built. Now that it has been installed, you should exclude exim in your yum.conf file.
yes you're right completely my fault however if you put this line in "/etc/yum.conf"

Code:
exclude=exim
yum skips the update to exim problem solved
 

PanelGuy

Well-Known Member
Oct 13, 2004
106
0
166
Exim over 4.52 and FC4

Does the new Exim 4.62 work with FC4 yet? Does anyone know for sure?