The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible to make cpanel username all caps?

Discussion in 'General Discussion' started by noimad1, Oct 27, 2009.

  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I have a customer who has a dedicated server. He is dealing with a company who is going to have an automated script log in and upload some very important files to him each month.

    However, this company is absolutely requiring that the username and password be in all CAPS.

    Is there anyway possible to setup a cpanel account with the username in all CAPS?
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I am not aware of an easy method to specifically force a cPanel account user name to be in all upper-case letters. The issue sounds like a problem that could be better resolved and more easily alleviated by a change in the custom script.
     
    #2 cPanelDon, Oct 27, 2009
    Last edited: Oct 27, 2009
  3. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16

    I wish I had the option to edit the custom script. The script was written by the state (a government agency) and that is there requirement and they won't change it.....arghhhhh.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    How is the custom software attempting to access the system?

    Is it attempting to login to cPanel?

    Is it attempting to login via SSH?

    Is it attempting to login via FTP?

    Is it attempting to login via a web form?

    Depending upon how the login occurs, it may be possible to add some intermediary step that converts the username to lower case during login.
     
  5. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    It looks like they will just be logging in through ftp.
     
  6. hostultra

    hostultra Well-Known Member

    Joined:
    Aug 21, 2002
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Using the linux adduser command, create a new username with all caps, set the user id and home directory the same as the lowercase username.

    that should allow the user to login to ftp.
     
  7. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for the info. I've looked up that command, and tried it, but it didn't work. Maybe I missed a flag or something. here is what I put:

    useradd -d /home/user/ -o -u 32014 -p PSWD USER

    Does that look rigtht?
     
  8. Seanformerlyof

    Joined:
    Mar 9, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    do you receive an error message?

    Because I tried using that command in the same way you're specifying and it works for me.

    How are you determining the uid?
     
  9. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    ln -n in their directory, then I assumed it was the first number, not the second.
     
  10. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I finally got it working...I opened a ticket with cpanel and they gave me some insite.

    Apparently after you create the user and assign it to the directory and such you have to create a file in the /etc/proftpd folder (even if you are using pure-ftp). So what I did was copy the lowercase file and rename it to upper case and changed the username in the file.

    Voila! I now have ftp access in full caps!

    Thanks for everyone's help!
     
Loading...

Share This Page