The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

postgres problem

Discussion in 'General Discussion' started by geraldo, Sep 13, 2003.

  1. geraldo

    geraldo Member

    Joined:
    May 1, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I installed postgresql following the structions here, however, when I access via X skin, I can create users, but when i tryed to create a database it shows it was created, however the db does not appear when I back... I tryed to access via phpPgAdmin but the user does not have access to it.. i put the same password and login used to connect via cpanel but it shows as invalid... Anyone here could help me to solve it??

    I installed everything correctly and the only thing I dont know if its correct is the mensage that appears when I installed...
    ....................................
    Rebuilding local rpm provides list.....postgresql-devel..Done
    [FAILED]
    postmaster: no process killed
    postmaster: no process killed
    Initializing database: [ OK ]
    Starting postgresql service: [ OK ]
    .........................

    what does this [FAILED] means?

    the others steps were all correct...

    PLEASE HELP;)

    thank you very much

    cPanel.net Support Ticket Number:
     
  2. deieno

    deieno Well-Known Member

    Joined:
    Nov 16, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Floripa - Brazil
    Did you solve this problem?

    Hi Geraldo,
    I have the same issue here. Since this post was to long ago, have you solve this problem?

    Thanks
     
  3. rsilviu

    rsilviu Member

    Joined:
    Sep 14, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Romania
    same problem here too

    same problem here too
     
  4. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Try running the following command:

    initdb -D /var/lib/pgsql/data

    and then reset the password via WHM.
     
  5. rsilviu

    rsilviu Member

    Joined:
    Sep 14, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Romania
    It's working!

    Thank you very much!
    You are the man! ;)
     
  6. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    I have some PostgeSQL problems myself.

    First, I ran that command line and got this:

    -bash-2.05b$ initdb -D /var/lib/pgsql/data
    The files belonging to this database system will be owned by user "chadi".
    This user must also own the server process.

    The database cluster will be initialized with locale en_US.UTF-8.
    This locale setting will prevent the use of indexes for pattern matching
    operations. If that is a concern, rerun initdb with the collation order
    set to "C". For more information see the Administrator's Guide.

    Fixing permissions on existing directory /var/lib/pgsql/data... chmod: changing permissions of `/var/lib/pgsql/data': Operation not permitted

    initdb failed.


    Why would it fail? I already intalled via update apache in WHM ---AND--- /scripts/instalpostgres

    I went into WHM and clicked "install" for PostgreSQL provided my password. I tried to create a database in cPanel for a test account but it does not create it (nor show it still). I logged into phpPgAdmin and it shows no database there as well.

    Please help
     
  7. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    By the way, I'm on Enterprise 3
     
  8. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Is your postgres super user named "chadi"? If not, that's why it's failing. You need to uninstall it and install it again.

    rpm -qa | grep postgres

    rpm -e whatever_is_returned_by_the_above_command

    /scripts/installpostgres
     
  9. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    I tried that second line and gave:

    error: Failed dependencies:
    postgresql = 7.3.6 is needed by (installed) rh-postgresql-server-7.3.6-7
     
  10. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Okay, so do

    rpm -e rh-postgresql-server-7.3.6-7

    before you do the others.
     
  11. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    Ok I'm confused....

    I ran in this order:

    rpm -e rh-postgresql-server-7.3.6-
    rpm -qa | grep postgres
    /scripts/installpostgres
    initdb -D /var/lib/pgsql/data (this part still gives the error below) Why?

    -bash-2.05b$ initdb -D /var/lib/pgsql/data
    The files belonging to this database system will be owned by user "chadi".
    This user must also own the server process.

    The database cluster will be initialized with locale en_US.UTF-8.
    This locale setting will prevent the use of indexes for pattern matching
    operations. If that is a concern, rerun initdb with the collation order
    set to "C". For more information see the Administrator's Guide.

    Fixing permissions on existing directory /var/lib/pgsql/data... chmod: changing permissions of `/var/lib/pgsql/data': Operation not permitted

    initdb failed.
     
  12. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    Also, it still does not show any databases in phpPgAdmin nor the Postgresql section of cpanel (of course because that script line is not working for me still)
     
  13. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    When you ran
    rpm -qa | grep postgres

    did you then delete everything that it listed by running rpm -e ?
     
  14. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    I was able to delete all but one "libs" it would not all me to delete due to "dependencies".

    Regardles, I reinstalled again and tried that last script initdb -D /var/lib/pgsql/data but still gives the error. How can I check who is the "owner" and correct it? I did everything through root except the last command initdb -D /var/lib/pgsql/data through "owner" chadi (as it would not allow me to do so via su).

    Please help me here.
     
  15. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Don't do it as "chadi". Do it as "postgres" or "root".
     
  16. cazny

    cazny BANNED

    Joined:
    Sep 3, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    I did it as root but it still will not allow me to delete libs.

    Also, when I install it I would have to do it as root or "chadi"?
     
  17. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    You have to do it as root. I suggest submitting a support ticket to wherever you got your cpanel license.
     
Loading...

Share This Page