The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PostgreSQL can not be accessed using JDBC

Discussion in 'Database Discussions' started by fidelcor, Jul 13, 2004.

  1. fidelcor

    fidelcor Member

    May 27, 2004
    Likes Received:
    Trophy Points:
    I have a customer that was having a problem with PostgreSQL.

    Message: PostgreSQLcan not be accessed using JDBC. It seems that postgres is running without "-i" option. To make postgres accessible, "-i" option must be added when postmaster gets started.

    Response: I reinstalled postgresql on your server. Check in you are able to use it with JDBC.

    Customer: No. still same.
    Please make sure postmaster is running with "-i" option. As long as I did "ps -ef | grep postmaster", it looks like postmaster is running without "-i" option as follows.
    ps -ef | grep postmaster
    postgres 14128 1 0 Jul02 ? 00:00:00 /usr/bin/postmaster -p 5432
    It should be "/usr/bin/postmaster -i -p 5432".
    Please check again.

    Then I ran this command in shell,

    root@sls-ce5p211 [~]# /scripts/installpostgres
    rm: cannot remove `/root/.cpupdates/pingtimes': Is a directory
    This script will install Postgres 7.3.x or later
    If you have an older version installed you wil need to
    Dump your databases to a file and then restore them
    after the install as 7.3.x is not backwards compatible.
    If you do not have any databases, you can just run:
    mv /var/lib/pgsql /var/lib/pgsql.old
    /sbin/service postgresql stop
    /sbin/service postgresql start
    to force creating a 7.3.x style setup. Do not do this if
    you have databases that you wish to keep!

    Are you sure you wish to proceed? no
    Bailing out!
    root@sls-ce5p211 [~]#
    root@sls-ce5p211 [~]# mv /var/lib/pgsql /var/lib/pgsql.old
    root@sls-ce5p211 [~]# /sbin/service postgresql stop
    root@sls-ce5p211 [~]#
    root@sls-ce5p211 [~]# /sbin/service postgresql start
    Initializing database: [ OK ]
    Starting postgresql service: [ OK ]
    root@sls-ce5p211 [~]#

    Customer: Still not. Actually, postgreSQL seems to be down now.

    What can I do to correct the problem? :confused:

Share This Page