The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

postgresql databases disappear

Discussion in 'General Discussion' started by fishfreek, Mar 20, 2004.

  1. fishfreek

    fishfreek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    238
    Likes Received:
    0
    Trophy Points:
    16
    I finally got postgresql working with php and two days later our client using this database sends me a message telling me all his databases are missing from cpanel and his scripts can no longer connect to them.

    I was obvsously very unhappy to read this after all the efforts to even get postgresql working in the first place.

    So I verifed that I could indeed not create postgresql databases in cpanel any more. So I tried a few things within WHM and via SSH and finally I got the darn thing creating databases again but where are the old ones? I dont know.

    Whats going on? Seems like cpanel's support and intergration of postgresql databases is margonal at best.

    We did zero changes on this server since getting postgresql working and then all of a sudden bang its no longer intergrating with cpanel and all the databases come up missing.
     
  2. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Disregard the date of the original post, we're having this same issue here. 0 replies to the 2 threads posted on the forums about this, and 0 bugzilla reports. What's the deal? Why would anything randomly rm a few pgsql dbs?


    edit: nevermind. The socket in /tmp had somehow gone missing, which was causing the databases to not appear in cPanel (since it couldn't connect to PostgreSQL).
     
    #2 randomuser, Feb 3, 2006
    Last edited: Feb 4, 2006
  3. SACHIN

    SACHIN Guest

    Same issue.

    Hello,

    I have the same problem in Portgress I was have reloaded my system and there was postgress connecting problem.

    The postgress problem is resolved but now I am facing the problem with the database not showing.

    I have tried running UPCP but the result is same.

    Can anyone help me getting back my postgress database back?

    Thanks in advance.
    Sachin.
     
  4. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    The only time I've seen the databases not show up in cPanel is when the postgres sockets went missing from /tmp. Do an "ls -al /tmp | grep postgres" and see if you have similiar files:

    Code:
    srwxrwxrwx    1 postgres postgres        0 Sep 17 03:52 .s.PGSQL.5432=
    -rw-------    1 postgres postgres       25 Sep 17 03:52 .s.PGSQL.5432.lock
    
    If not, you may need to start postgres via:
    /etc/rc.d/init.d/postgres start
     
  5. SACHIN

    SACHIN Guest

    Yes , there is the output as follows
    -rw-r--r-- 1 postgres postgres 0 Oct 1 07:47 dbdo28.out
    srwxrwxrwx 1 postgres postgres 0 Oct 11 09:02 .s.PGSQL.5432=
    -rw------- 1 postgres postgres 25 Oct 11 09:02 .s.PGSQL.5432.lock

    and I also Restart the service,but still database is not visible,please suggest.
     
  6. useradmin

    useradmin Well-Known Member

    Joined:
    Oct 8, 2004
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    INDIA
    postgres database disapear

    HI,


    I am also getting same problem i tried all things which is mention above but still no luck..
     
Loading...

Share This Page