Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

postgresql failed @ Sun Aug 22. A restart was attempted automagicly.

Discussion in 'General Discussion' started by nybble, Aug 22, 2004.

  1. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    Err, I haven't touched this box and yet it failed? Any ideas? cPanel update **** something up?

    <edit>Failed 80 times~ and counting</edit>
     
    #1 nybble, Aug 22, 2004
    Last edited: Aug 22, 2004
  2. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Have you investigated the problem any further?

    It looks like its failing because it's not even starting. So every time chkservd runs, it will send you a message that it has failed. Try starting postgresql manually and see why its failing.

    What is the content of /etc/chkserv.d/postgresql?

    Do you have postgresql configured to listen on TCP sockets?
     
  3. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    Its been fine till now :)
     
  4. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    /scripts/restartsrv postgresql
    Waiting for postgresql to restart..............finished.


    postgresql has failed, please contact the sysadmin (result was "postmaster is not running").


    Better yet, is there a way to turn off postgresql? (So users cant use it and it's not running)
     
    #4 nybble, Aug 22, 2004
    Last edited: Aug 22, 2004
  5. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Sure, just touch /etc/disablepostgresql, then uninstall it. Then rename the postgresql directory (usually /var/lib/pgsql). Let me know if that doesn't remove all remnants of it in the WHM/cPanel.
     
  6. Suter Rainer

    Suter Rainer Well-Known Member

    Joined:
    Jul 24, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    156
    Postgresql

    we have the same problem
     
  7. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    I just asked one of my admins to fix it and they did.... err, nice of them not to tell me what's wrong :)
     
  8. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    168
    You may want to have a look at this thread.
     
  9. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    Nah, it only had to be started up :) it managed to fail after the cpanle update (figures)

    Maybe you guys should make something like SIM.
     
  10. i3903

    i3903 Well-Known Member

    Joined:
    Apr 27, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    156
    We started getting these after todays cpanel update.
     
  11. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    The cpanel update stops postgres, you need to start it again.


    type "service postgres start" in the command prompt.
     
  12. DrChaos

    DrChaos Active Member

    Joined:
    Dec 23, 2001
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    306

    We are having the same issue after updates and tried that and the result is "postgres: unrecognized service"
     
  13. nybble

    nybble Well-Known Member

    Joined:
    Jan 26, 2004
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    166
    try "postgresql" or "postgres" and even try adding a d to the end.

    eg.

    postgresd =\
     
  14. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    168
    Same problem, also after cpupdate.

    trying to start the service manually (service postgresql start) returns:


    Initializing database: su: user postgres does not exist
    [FAILED]
    Starting postgresql service: su: user postgres does not exist
    [FAILED]


    I can remember setting a password for postgre when first configuring this box, but I don't believe I (or anyone else) actually using it...
     
  15. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    168
    Ok, more checking showed that some of the packages weren't showing up as being installed... reinstalled postgresql and all is well.

    I used the instructions from this thread
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice