The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PostgreSQL Install / Create DB users of pre-existing users fail silently

Discussion in 'Database Discussions' started by livreti, Jul 10, 2012.

  1. livreti

    livreti Registered

    Jan 3, 2012
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Main >> SQL Services >> Postgres Config

    Under "Create Postgres Users", when I click the "Create Users" button, it goes to the next page and returns "PostgreSQL users created".

    But no previously created account Pg user is added! :eek:

    How do I debug this? How do I run the "Create users" under command line? ( if possible )

    I'm an experienced linux admin, I've managed to pinpoint the form action of "createpostgresusers" to /usr/local/cpanel/whosting/bin/whostmgr2. Apart from this, I have no Idea how it should run.

    Will I have to manually add the users? How about the password?
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Oct 2, 2010
    Likes Received:
    Trophy Points:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Re: PostgreSQL Install / Create DB users of pre-existing users fail silentl

    This appears to be an internal case we've opened at this point. That area is indeed failing. Right now, the way to overcome the issue is for the user in their cPanel to go to PostgreSQL Databases section, since that then loads the user. The internal case on the issue is 60262 and the changelog when it is pushed into one of the tiers can be viewed at Change Logs


Share This Page