The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

postgreSQL not working with Linux enterprise.

Discussion in 'General Discussion' started by dom182, Jan 26, 2004.

  1. dom182

    dom182 Member

    Joined:
    Nov 12, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    Hello,

    postgreSQL not working with Linux enterprise Why?
    Is thia a bug of cpanel
    Please describe me,

    Thanks in advance.



    Regards,
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Send in a support ticket to cPanel. Be sure to include login information for your box.
     
  3. dom182

    dom182 Member

    Joined:
    Nov 12, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    reply

    Hello,

    I know postgreSQL and exim have a buggs with Linux enterprise.When this problem will be resolved.
    Please upldate me very soon.

    Thanks in advance.

    Regards,
    Dom182
     
  4. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    1. Delete the postgre files in /tmp.
    2. rm -rf /var/lib/pgsql/data
    3. su - postgres
    4. initdb
    5. start postgre from ssh
    6. Go back and try the WHM functions again.


    After doing #4 the msg. ends with:

    Success. You can now start the database server using:

    /usr/bin/postmaster -D /var/lib/pgsql/data
    or
    /usr/bin/pg_ctl -D /var/lib/pgsql/data -l logfile start

    Chose the first option or start Postgres from WHM.

    Using RH 9 this worked for me. :)
     
  5. dom182

    dom182 Member

    Joined:
    Nov 12, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    Not working

    Hello,

    When i connect to pgsql via php i face the following error :

    Warning: pg_connect(): Unable to connect to PostgreSQL server: FATAL: IDENT authentication failed for user "fotolis" . in /home/fotolis/public_html/testing.php on line 5

    Some conf. are given below :
    ==================================
    /var/lib/pgsql/data/pg_hba.conf

    # TYPE DATABASE USER IP-ADDRESS IP-MASK METHOD

    local all all trust
    host all all 127.0.0.1 255.255.255.255 trust

    # Using sockets credentials for improved security. Not available everywhere,
    # but works on Linux, *BSD (and probably sote others)

    local all all ident sameuser
    ==================================
    /var/lib/pgsql/data/pg_ident.conf

    # TYPE DATABASE USER IP-ADDRESS IP-MASK METHOD
    local all all trust
    host all all 127.0.0.1 255.255.255.255 trust
    ==================================

    Please help me asap.

    Thanks in advance.

    regards,
    DOM
     
  6. 3en

    3en Active Member

    Joined:
    May 21, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I now get that error any fix?
     
  7. SACHIN

    SACHIN Guest

    same error

    Hello

    psql: FATAL: IDENT authentication failed for user "User_test"


    same error any fix???????
     
  8. SACHIN

    SACHIN Guest

    fix...

    I got the same error.

    i have tried following solution..

    Make sure the password is in /var/lib/pgsql/.pgpass
    The format is as follows... *:*:*:postgres:PASSWORD
    Modify /var/lib/pgsql/data/pg_hba.conf
    It should contain the following...
    local all all md5
    host all all 127.0.0.1 255.255.255.255 md5
    Change 'md5' to 'trust' to disable authentication then restart postgres.
    `/etc/init.d/postgresql restart`
    Now you should be able to connect to postgresql as user 'postgres' without a password to modify the password.
    `psql -u template1` Run the following sql command.
    "alter user postgres with password 'NEW PASSWORD HERE';"
    Finally change /var/lib/pgsql/data/pg_hba.conf back to its original format and restart postgresql one more time. Now you

    should be able to authenticate using user postgres and the password you specified


    psql -u databasename
    username
    password

    It is working fine now.

    i am still unable to connect using forum..

    help me
     
Loading...

Share This Page