Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PostgreSQL postmaster with -i option

Discussion in 'General Discussion' started by deddy, May 2, 2004.

  1. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    166
    The manually command
    /usr/bin/postmaster -D /var/lib/pgsql/data -i
    enables TCP/IP connections to Postgresql
    databases.

    The restart service within WHM is killing
    this setting. postmaster.opts file is generated
    automatically
    /usr/bin/postmaster '-p' '5432'

    I tried to change /etc/rc.d/init.d/postgresql
    without any success. The start up of the postmaster
    fails as soon as I enter the -i option there.

    I'm sure I'm overlooking something.

    Is there anybody out there who is running postmaster
    with the -i option through the WHM restart service ?
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    191
    Really? Have you confirmed this? The settings are done in /var/lib/pgsql/data/postgresql.conf

    tcpip_socket = true

    port = 5432

    Uncomment those.
     
  3. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    166
    Unfortunately it is not able to fix that problem.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice