candemasjor

Registered
Apr 5, 2020
2
0
1
Comunidad Valenciana, España
cPanel Access Level
Reseller Owner
my PostgreSQL server is very trouble, before done fix install PostgreSQL many times step

Code:
The Postgres database is not initialized. The system will now initialize it.Los archivos de este cluster serán de propiedad del usuario «postgres». Este usuario también debe ser quien ejecute el proceso servidor. El cluster será inicializado con configuración regional «es_ES.UTF-8». La codificación por omisión ha sido por lo tanto definida a «UTF8». La configuración de búsqueda en texto ha sido definida a «spanish». initdb: el directorio «/var/lib/pgsql/12/data» no está vacío Si quiere crear un nuevo cluster de bases de datos, elimine o vacíe el directorio «/var/lib/pgsql/12/data», o ejecute initdb con un argumento distinto de «/var/lib/pgsql/12/data». Done Waiting for “postgresql” to start ………failed.

Cpanel::Exception::Services::StartError Service Status

Service Error
(XID ek3sam) El servicio “postgresql” no se pudo iniciar.
The “postgresql” service failed to start.

Startup Log
May 08 20:25:27 host.candemasjor.cf systemd[1]: Starting PostgreSQL database server...
May 08 20:25:27 host.candemasjor.cf systemd[1]: postgresql.service: control process exited, code=exited status=1
May 08 20:25:27 host.candemasjor.cf systemd[1]: Failed to start PostgreSQL database server.
May 08 20:25:27 host.candemasjor.cf systemd[1]: Unit postgresql.service entered failed state.
May 08 20:25:27 host.candemasjor.cf systemd[1]: postgresql.service failed.

postgresql has failed. Contact your system administrator if the service does not automagically recover.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
How did you install PostgreSQL? cPanel only supports the operating system provided version which is 9.2.24 currently and it looks like you're using version 12 based on the error.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
I'm not sure I understand fully what you're saying but I think you mean you needed version 12? If so would suggest enlisting the assistance of a qualified system administrator as cPanel does not provide support for this version of PostgreSQL, if you don't have one you might find one here: System Administration Services