Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Premature end of script error -- tried everything... Any help?

Discussion in 'General Discussion' started by 3p6hsmg, Dec 1, 2011.

  1. 3p6hsmg

    3p6hsmg Member

    Joined:
    Dec 1, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Website Owner
    I have searched and tried many solutions and cannot fix this issue. Here is the error:

    Code:
    [Fri  Dec 02 00:26:43 2011] [warn] [client xxx.xxx.xxx.xxx] (104)Connection  reset by peer: mod_fcgid: error reading data from FastCGI server
    [Fri Dec 02 00:26:43 2011] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: index.php
    [Fri Dec 02 00:26:48 2011] [error] mod_fcgid: process  /usr/local/cpanel/cgi-sys/php5(16037) exit(communication error), get  unexpected signal 11
    
    
    No matter what I do, a 500 server error is thrown on this page. It worked fine 1 week ago and it works fine on the development server. There are no other errors that I can find. If anyone has any hints, please let me know. I am running apache 2.2 and php 5.3.8.

    I have tried:

    1) Deleting the suphp, suexec, and apache error log

    2) Changing php versions

    3) Changing handlers (dso, cgi, fastcgi)

    4) Enabling and disabling php suexec

    5) Disabling and enabling eaccelerator

    6) ensuring all folders/files in my web root belong to me

    7) no errors in the suexec log

    8) no errors in the web root apache log... Only the above errors in the main apache log
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Do you get the same error message when you run the PHP file from the command line? You can try with a command like this:

    Code:
    # php /home/username/public_html/index.php
    Let me know the results.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    11
    Trophy Points:
    168
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Do you have a CMS running in that site?
    I had similar problems in a Joomla site, and finally I found out it was because of a (self-made) Joomla template.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice