linux25

Member
Oct 6, 2009
6
0
51
Hi,

I am trying to enable SUPHP on my WHM server. No websites will work with SUPHP enabled. Every site on the server returns similar to the following in Apache error_log:

[Sun May 25 15:53:47 2014] [error] [client 71.29.205.197] Premature end of script headers: index.php

I have set the perms to 644 for scripts and 755 for directories. The owners and groups are all set to the user. I have checked the suphp error log and it is not over 2GB. (Read in a forum that might be the cause).

No avail. I am still getting 500 Internal Server Errors.

Please help!

Any help will be greatly appreciated.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello :)

Could you post the output from /usr/local/apache/logs/error_log when you notice the "500" error code in your browser? Are you sure "Premature end of script headers" is the only aspect of the output in the Apache error log?

Thank you.
 

linux25

Member
Oct 6, 2009
6
0
51
Solved -- One of the configuration settings in EasyApache brought in apc.so, which is not compatible with suphp. No longer getting error.

Thank you,

Jeff Small
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.