SOLVED Prevent cpsrvd from serving standard HTTP ports ? I have this setting ON, could be the reason why AutoSSL is not working?

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator
I was just reading this here and it seems it's saying that AutoSSL is rendered unusable if we have this setting ON?


Important:
This action renders any cPanel & WHM features that depend on the standard HTTP ports partially or entirely unusable
. These features include service subdomains, AutoSSL, Mailman, and BoxTrapper.

- Am I reading this correctly?

- Could this be everyone's issue with AutoSSL not renewing if this setting is ON ?

I have 2 cpanel accounts that are about to expire.
one is 3 days still nothing
another is 7 days

I have this feature set to: "ON" I am using autom8n plugin for Nginx on these 2 cpanel sites so I believe now looking at this it has different ports instead of 80 and 443

so would this create any issues with AutoSSL ?

thanks I might not be reading this tweak correctly. if anyone can chime in and let me know.


Prevent cpsrvd from serving standard HTTP portsThis setting prevents the cpsrvd daemon from taking over the standard HTTP ports when you disable the system’s web server role.
Important:
This action renders any cPanel & WHM features that depend on the standard HTTP ports partially or entirely unusable. These features include service subdomains, AutoSSL, Mailman, and BoxTrapper.
  • On — Enable.
  • Off — Disable.
Off


Kind Regards,
Spiro
 
Last edited:

Spirogg

Well-Known Member
Feb 21, 2018
696
151
43
chicago
cPanel Access Level
Root Administrator
ok just spoke to the developer of Autom8n and these settings have been like this since the beginning of their plugin. Autom8n is a Nginx
so I don't think the issue is the plugin or this setting for me.. just the cPanel AutoSSL issue that is currently going on.

You can either delete or mark this post as solved.

sorry and thanks
Spiro
 
  • Like
Reactions: cPRex