The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

prevent email to queue

Discussion in 'E-mail Discussions' started by alfa ex, Dec 15, 2015.

  1. alfa ex

    alfa ex Member

    Joined:
    Oct 15, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    hi.

    i can't find any option to prevent email from queue.
    When i send and e-mail i want to that email goes to the word at the same time.

    Now the email stay a long period on the queue.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Messages only remain in the queue if the initial delivery attempt fails. Could you attempt to deliver a message in the queue or review /var/log/exim_mainlog to see why the initial delivery attempt failed? EX:

    Code:
    exigrep user@domain /var/log/exim_mainlog
    Thank you.
     
  3. alfa ex

    alfa ex Member

    Joined:
    Oct 15, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi.

    i don't know why but for every body start to show "SMTP AUTH is required for message submission on port 587" so i deactivated the option "Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server. " restart the exim both problem was resolved.


    Code:
    2015-12-15 16:10:18 H=xxx-xxx-xx-xxx.dial-up.telesp.net.br ([192.168.0.101]) [xxx-xxx-xx-xxx]:53831 F=<myemail@mydomain.com> rejected RCPT <myemail@mydomain.com>: SMTP AUTH is required for message submission on port 587
    
    2015-12-15 16:11:39 SMTP connection identification H=xxx-xxx-xx-xxx.dial-up.telesp.net.br A=xxx-xxx-xx-xxx P=53846 U=istsiste ID=503 S=myemail@mydomain.com B=get_recent_authed_mail_ips_entry
    
    2015-12-15 16:11:39 H=xxx-xxx-xx-xxx.dial-up.telesp.net.br ([192.168.0.101]) [xxx-xxx-xx-xxx]:53846 F=<myemail@mydomain.com> rejected RCPT <lambaocf@hotmail.com>: SMTP AUTH is required for message submission on port 587
    
    2015-12-15 16:15:05 H=xxx-xxx-xx-xxx.dial-up.telesp.net.br ([192.168.0.101]) [xxx-xxx-xx-xxx]:53883 F=<myemail@mydomain.com> rejected RCPT <myemail@mydomain.com>: SMTP AUTH is required for message submission on port 587
    
    2015-12-15 16:17:51 SMTP connection identification H=xxx-xxx-xx-xxx.dial-up.telesp.net.br A=xxx-xxx-xx-xxx P=53996 U=istsiste ID=503 S=myemail@mydomain.com B=get_recent_authed_mail_ips_entry
    
    2015-12-15 16:17:51 H=xxx-xxx-xx-xxx.dial-up.telesp.net.br ([192.168.0.101]) [xxx-xxx-xx-xxx]:53996 F=<myemail@mydomain.com> rejected RCPT <lambaocf@hotmail.com>: SMTP AUTH is required for message submission on port 587
    
    thanks for the reply
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's likely the failing users were not using SSL to make the SMTP connection in their email client. Thus, disabling that option allows them to send out email successfully.

    Thank you.
     
  5. alfa ex

    alfa ex Member

    Joined:
    Oct 15, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Almost no one use ssl to send email with outlook.

    Thanks a lot @cPanelMichael

    ps: it's allowed to put [SOLVED] on the title?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page