Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Prevent “nobody” from sending mail in server with smarthost

Discussion in 'E-mail Discussions' started by jorgearellano, Oct 7, 2015.

  1. jorgearellano

    jorgearellano Member

    Joined:
    Jun 5, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Tepic Nayarit México
    cPanel Access Level:
    Reseller Owner
    Twitter:
    I have configured my server prevent "nobody" from sending email ON

    But my ISP sends the mail through a smarthost, and nobody user can send emails.

    As I can prevent that nobody send emails if the server has smarthost?
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,480
    Likes Received:
    60
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    Which php handler are you using on your server ?

    Preventing the nobody system user from sending mail will be work when PHP and CGI scripts generally run as nobody when the system is using mod_php, or when suEXEC is disabled on the server. If you enable SuExec and SuPHP so that scripts should no longer be running as user nobody. Instead, these scripts run as the actual cPanel user.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    I suggest implementing rules on the smart host to prevent outgoing emails from certain users such as "nobody".

    Thank you.
     
Loading...

Share This Page