Prevent outdated executables

Remus76

Member
Apr 12, 2016
17
2
53
Romania
cPanel Access Level
Root Administrator
Hello!
First I must say I am a total noob, with basic knowledge about cPanel and Linux.

I ran Security Advisor and got a message about outdated executables that need a reboot.
Then I found with needs-restarting:
1 : /usr/lib/systemd/systemd --system --deserialize 21
and ran systemctl daemon-reexec, which solved the problem.

I wonder if this can be prevented if this command is used directly when there are outdated executables, after updating cPanel or system.