The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Prevent the user 'nobody' from sending out mail to remote addresses

Discussion in 'E-mail Discussions' started by DWHS.net, Jun 25, 2003.

  1. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Hello,

    Just to be sure that the option "Prevent the user 'nobody' from sending out mail to remote addresses: Will this block all php scripts that send email using php for the email sender?

    And sendmail too?

    Like phpbb and inkovision?

    Or is it just some scripts that send out email as "nobody"

    Is there a way to disable this per domain or vise versa?

    Thanks,

    -Charles

    cPanel.net Support Ticket Number:
     
  2. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    It prevents any mail from being sent out from user nobody (e.g. if your not running phpsuexec that would mean any mail from php scripts) as far as i know it is not possible to do it on a per domain basis

    cPanel.net Support Ticket Number:
     
  3. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    So you think if I have the phpsuexec mod installed, php can send emails with this option on?

    Thanks..............:D

    cPanel.net Support Ticket Number:
     
  4. marius

    marius Well-Known Member
    PartnerNOC

    Joined:
    Jun 10, 2002
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bucharest
    nobody suexec

    hi there,

    i have the option "prevend user nobody .." checked.
    i have suexec enabled.

    but still.. mail can be sent as user nobody. i searched the forums for 2 days now.. but.. cannot figure it out. can somebody pls tell me what is wrong?

    WHM 7.2.0
    Cpanel 7.2.1-S85
    RedHat 8.0
     
  5. ricoche

    ricoche Well-Known Member

    Joined:
    Feb 7, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    I'd like to know the answer to this as well. "Bump"

    Thanks! :)

    cPanel.net Support Ticket Number:
     
  6. scanreg

    scanreg Member

    Joined:
    Jan 21, 2008
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    if i enable this, then would i be correct in thinking that the only way for a script to send out mail to a remote email addy is if a real user is used by the script to send the mail ?

    in other words, the outgoing email would be sent by "support@mysite.com" with user/pass/smtp etc ?

    i'd like to enable this but don't want to block scripts from sending to remote email addresses

    thanks
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,466
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    This thread is from 2003. Why bump this old thread?
     
  8. scanreg

    scanreg Member

    Joined:
    Jan 21, 2008
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    was the closest so far that i've found

    wanted to understand if using a real user to send mail is the key to enabling the prevent-nobody feature, before triggering this feature
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,466
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page