The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem accessing web sites on server

Discussion in 'General Discussion' started by Bdzzld, Jan 17, 2006.

  1. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi,

    I'm having a problem with a x86_64 dual opteron server with 300+ accounts.

    During peek hours - when the server load rises to above 1.x levels for a few moments (normal server load is around 0.30) - some clients report problems loading their web pages from web sites on the server. The problems can last from a few seconds to a minute and seems to hang. Afterwards there are no problems any more.

    Any ideas what this is and off course how to solve this?

    Thanks,
    Bdzzld.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Check the httpd error_log for errors when this happens. You might be hitting MaxClients. If you have a lot of mysql driven accounts, you may also be hitting /etc/my.cnf max_connections

    If it's a general slow-down, check swapfile usage in top incase you're memory-thrashing.
     
  3. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi,

    Thanks for your answer.

    I've checked the httpd error_log @ /etc/httpd/logs but could not find anything out of the ordinary. max_connections for /etc/my.cnf are already set to : 500. Also swapfile usage is no more than 1% the entire time.

    I've set "ulimit -n" (open files) from 1024 to 4096 and hope that will make some diff...

    Any other suggestions are always welcome...
     
  4. MMarko

    MMarko Well-Known Member

    Joined:
    Apr 18, 2005
    Messages:
    316
    Likes Received:
    0
    Trophy Points:
    16
    Did you check mysql as Chirpy said before?

    Did you optimize mysql and php?
     
  5. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    max_connections for /etc/my.cnf are already set to : 500. Should be sufficient I guess...

    Don't want to sound stupid, but how does one do such a thing?
     
  6. neonix

    neonix Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    124
    Likes Received:
    2
    Trophy Points:
    0
  7. MMarko

    MMarko Well-Known Member

    Joined:
    Apr 18, 2005
    Messages:
    316
    Likes Received:
    0
    Trophy Points:
    16
    Check memory settings for mysql cache too!

    Well you go to their site and search for "performance optimization" in documentation :D

    PHP can be tweaked using some precompilers and caching software like zend optimizer etc...
     
Loading...

Share This Page