The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem after mysql update

Discussion in 'General Discussion' started by ramil, May 24, 2006.

  1. ramil

    ramil Active Member

    Joined:
    Dec 28, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    after updating form 4 to 4.1 mysql works, but I am unable to login via phpmyadmin with error message Access denied for user 'root'@'localhost' (using password: YES)', and sites with php/mysql are not working, I already made changes on mysql root password, but no sucess...

    Regards
     
  2. inventor

    inventor Member

    Joined:
    May 14, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    Can you check this case : Use old style (4.0) passwords with mySQL 4.1 (required if you have problems with php apps authenticating)
     
  3. ramil

    ramil Active Member

    Joined:
    Dec 28, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    yes, but no success..

    a mysqld is running, even a Horde! but there is a prblem with other sites with php+mysql, when trying to open sites, its loading for a long time, and when try command 'mysql', got an error:

    Access denied for user 'root'@localhost'....
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Did you do what inventor suggested and added the old password directive in /etc/my.cnf?
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Adding

    old-passwords

    to the [mysqld] section in /etc/my.cnf

    and running /scripts/restartsrv_mysql

    should be effective

    If note

    try

    /scripts/mysqlconnectioncheck
     
  6. ramil

    ramil Active Member

    Joined:
    Dec 28, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    finally I did it! :)

    I have this problem after updating cpanel to latest stable version...

    If you are running a latest stable version of cpanel and FedoraCore 4, dont run upcp with mysql upgrading, the versions of mysql 4.0.26, 4.0.27, 4.1.x are not running properly, you will get a lot of errors like:
    - no pid file found...
    - no sock file found...
    - user mysql not found...
    - access denied for user 'root@localhost'
    - or if Mysql 4.1.x is running but you have a high server loads etc.

    just do the following (downgrading to Mysql 4.0.23):

    1. Remove mysql from your system
    yum remove mysql *
    2. go to http://updates.cpanel.net/mysqlinstall/i386/ and download all rpm files except Mysql-bench
    3. Run 'rpm -Uvh MySQL-*.rpm --force'
    4. Run 'service mysql start' or '/scripts/restartsrv_mysql'

    Thats all ;)
     
  7. kemis

    kemis Well-Known Member

    Joined:
    Feb 17, 2005
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Georgetown, TX
    As I search the threads, I see that others are now having this exact same problem lately (including myself!). So it seems to me this is something bigger than a single user with a misconfiguration problem.

    I have cpupdate disabled, but evidently the "System Software" update still runs automatically. Well, last night I got auto-updated to 4.1.19. Since then, I also have Web sites that get the access is denied error, and cpbackup itself can't backup the mysql databases because of the same access is denied problem!

    I verified that I do have the "old-passwords = 1" option in my /etc/my.cnf (but I set this through WHM --> Tweak Settings). I also restarted the service using /scripts/restartsrv_mysql but it didn't help. Finally, /scripts/mysqlconnectioncheck simply returned me to the prompt with no output. Is this normal?

    Anyway, I just wanted to say I'm in this boat, too, now. Does anyone know why the autoupdate caused these problems? Is cPanel doing anything about it? I guess I can go poke around their bugzilla db. I'll go do that now...

    -- Matt
     
  8. kemis

    kemis Well-Known Member

    Joined:
    Feb 17, 2005
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Georgetown, TX
    Fixed my own problem, too, Ramil! I did it by simply going to WHM --> Change a User or Database Password and resetting my mysql root password back to my usual.

    All is well again, I believe.

    -- Matt
     
Loading...

Share This Page