Problem backing up system files to remote destination

Flyer

Member
Jun 15, 2007
18
0
51
I've configured backup (non-legacy) in 11.40.1 to backup accounts and system files and transfer them to a NAS account by FTP. The local copies of the backups are created as expected in subdirectories called "accounts" and "system". If the backup type is set to uncompressed, the full directory tree is transferred to NAS storage, but when set to compressed, only the zipped account files are transferred, so system files are not backed up. In either case, the email notification does not record the FTP transfer.

Is this behaviour correct?
 

Flyer

Member
Jun 15, 2007
18
0
51
Incidentally, why the different behaviour when the files are compressed? System files are automatically backed up to the NAS server when uncompressed, but an option has to be manually added to a config file to back them up when they're compressed. It seems more like a bug report is required, rather than a feature request.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
It's a feature request because there is no support to enable the system backups via the UI for remote destinations. It would be classified as a bug report if there was an option to enable system backups for remote destinations in the UI and it did not work. Note that it's fairly easy to enable it via the command line with the instructions from the document provided.

Thank you.
 

Flyer

Member
Jun 15, 2007
18
0
51
I can't have made myself clear. System files are backed up to the remote destination, without adding "upload_system_backup: 1" to the backup configuration file, but only if the option to compress them is not set.

Is that a bug or a feature?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Yes, it's still a feature request if you would like to see the ability to enable system backups for remote destinations for all backup types via the WHM user interface.

Thank you.