The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem compiling apache with php 5.2

Discussion in 'EasyApache' started by tcaetano, Nov 12, 2006.

  1. tcaetano

    tcaetano Active Member

    Joined:
    May 15, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Faro > Portugal
    Hi

    I got a new VPS with Cpanel and want to get it with MySQL5 and php5.

    No problem with MySQL5 but when I try to compile apache I get the following output:

    Code:
    ...
    Fetching http://httpupdate.cpanel.net/buildapache/1/libxml2-2.6.22.tar.gz (0)....@198.66.78.11......connected......receiving...1%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
    
    ./configure [@libxml2-2.6.22]...(--prefix=/usr).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make [@libxml2-2.6.22]...(-j 1).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make [@libxml2-2.6.22]...(install).... . . . . Done
    
    Fetching http://httpupdate.cpanel.net/buildapache/1/php-5.2.0.tar.gz (0)....@198.66.78.12......connected......receiving...1%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
    Untarring php....Done
    Running configure:
    LDFLAGS="-L/usr/X11R6/lib64" /home/cpapachebuild/buildapache/callbacklog --prog configure --dir /home/cpapachebuild/buildapache/build-log --  --with-apxs=/usr/local/apache/bin/apxs  --prefix=/usr/local --with-xml    --enable-bcmath --enable-calendar  --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli  --with-mysql=/usr  --enable-discard-path  --with-pear  --enable-sockets --enable-track-vars --with-zlib 
    
    ./configure [@php-5.2.0]...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make [@php-5.2.0]...(-j 1 clean).... Done
    
    make [@php-5.2.0]...(-j 1).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    [COLOR="Red"]make: *** [Zend/zend_execute.lo] Error 1[/COLOR]
    
    make [@php-5.2.0]...(install).... . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    [COLOR="Red"]make: *** [Zend/zend_execute.lo] Error 1[/COLOR]
    /etc/rc.d/init.d/httpd start: httpd started
    
    ./configure [@php-5.2.0]...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make [@php-5.2.0]...(-j 1 clean).... Done
    
    make [@php-5.2.0]...(-j 1).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    [COLOR="Red"]make: *** [Zend/zend_execute.lo] Error 1[/COLOR]
    
    make [@php-5.2.0]...(install).... . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    [COLOR="Red"]
    make: *** [Zend/zend_execute.lo] Error 1[/COLOR]
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to 
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    initfpsuexec: using apache 1.x support
        
    Attempting to restart httpd 	
    
    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.
    
    
    
    
    httpd status
    
    root     30372  0.1  0.1  5548 2400 ?        Ss   10:05   0:00 /usr/local/apache/bin/httpd -DSSL
    
    
    
    
    httpd started ok
    
    
    
    
    
    
    
    Build Complete
    
    
    After this PHP doesnt work.

    I searched over many forums and tryed different things and nothing works...

    Also tryed with php 5.1.6, 5.1.4 and 5.0.4 and only with php4 php is compiled.

    Hope that someone have a clue how this could be solved!

    Thanks

    TIAGO
     
  2. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    867
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    AFAIK, the latest zend ( 3 ?) dose not work with php5.2 yet.
     
  3. tcaetano

    tcaetano Active Member

    Joined:
    May 15, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Faro > Portugal
    I know, but with php 5.1.4 or 5.1.6 it gives the exact same error...
     
  4. carluk

    carluk Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    16
    What options are you using and which cpanel build?
     
  5. tcaetano

    tcaetano Active Member

    Joined:
    May 15, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Faro > Portugal
    The problem was related with the VPS being out of memory.

    The company that provide the VPS managed to do it.

    Thanks
     
Loading...

Share This Page