Problem creating mysql users when options were change in the mysql configuration

coolfiger

Registered
Nov 10, 2013
3
0
1
cPanel Access Level
Root Administrator
Good Day,

We recently activated STRICT_TRANS_TABLES which is a global mysql setting. about 15 of our clients use this feature and require it on.

Since we turned this account on we cannot create any mysql accounts . Se the attached file for the error.

ran adminbin cpanel/cpmysql/Adduser

Capture.PNG

From all my reading there seems to be no way to overcome this except turning the strict trans option off.

Can you suggest any solutions ?
 

coolfiger

Registered
Nov 10, 2013
3
0
1
cPanel Access Level
Root Administrator
this is the output from your cmd
# mysqladmin variables | grep sql_mode
| sql_mode | STRICT_TRANS_TABLES

Server version: 5.1.70-cll - MySQL Community Server (GPL)

- - - Updated - - -

forgot to include cpanel version WHM 11.38.2 (build 12)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Check to see if you have an additional my.cnf file added to the system. EX:

Code:
/usr/my.cnf
Also, what's the specific entry you have in /etc/my.cnf related to this variable?

Thank you.
 

coolfiger

Registered
Nov 10, 2013
3
0
1
cPanel Access Level
Root Administrator
there is no additional my.cnf file on the server, the only one is /etc/my.cnf, and the variable in question within it is:
sql_mode=STRICT_TRANS_TABLES

Actually here is the entire my.cnf content if you will need it:
[email protected] [~]# cat /etc/my.cnf
[mysqld]
max_connections=500
log-slow-queries
#safe-show-database
sql_mode=STRICT_TRANS_TABLES
#skip-networking
skip-locking
connect_timeout=300
key_buffer=16M
join_buffer=1M
record_buffer=1M
sort_buffer=2M
table_cache=1028
thread_cache_size=286
max_allowed_packet=5M
wait_timeout=300
query_cache_limit=1M
query_cache_size=32M
query_cache_type=1
thread_concurrency=2
local-infile=0
open_files_limit=13756
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
I suggest opening a bug report if you are using a version of MySQL that supports this value:

Submit A Bug Report

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
To update, it looks like this option did remain enabled on MySQL 5.1 after restarting MySQL.

Thank you.