Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem editing php.ini

Discussion in 'General Discussion' started by silue massaillon, Nov 4, 2016.

Tags:
  1. silue massaillon

    silue massaillon Registered

    Joined:
    Nov 4, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Abidjan
    cPanel Access Level:
    Root Administrator
    hi Everyone
    for increasing the php memory size and other php parameters I created manually a php.ini using some text editor and I pasted the following in it and saved the file :::

    safe_mode = Off
    memory_limit = 256M
    post_max_size = 256M
    upload_max_filesize = 256M

    despite that the changes don't affect the php parameters as they remain unchanged

    could you please help

    thanks
     
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    569
    Likes Received:
    40
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Please check which php.ini file is using for your website. You have to create phpinfo file and check php.ini file path.
     
  3. danielpmc

    danielpmc Well-Known Member

    Joined:
    Nov 3, 2016
    Messages:
    64
    Likes Received:
    28
    Trophy Points:
    18
    Location:
    Gainesville, Florida
    cPanel Access Level:
    Reseller Owner
    Hello silue massaillon,

    You can try placing this in your public_html/.htaccess instead of creating a php.ini file.

    AllowOverride Options
    AllowOverride All
    safe_mode = Off
    memory_limit = 256M
    post_max_size = 256M
    upload_max_filesize = 256M
     
  4. silue massaillon

    silue massaillon Registered

    Joined:
    Nov 4, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Abidjan
    cPanel Access Level:
    Root Administrator
    hi @SysSachin I tried what you mentioned but the is the path is a linux path and I don't know how to access the path for accessing the right php.ini
     
  5. silue massaillon

    silue massaillon Registered

    Joined:
    Nov 4, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Abidjan
    cPanel Access Level:
    Root Administrator
    hi daniel

    I tried this way too but still no affecting the php parameter.
     
  6. danielpmc

    danielpmc Well-Known Member

    Joined:
    Nov 3, 2016
    Messages:
    64
    Likes Received:
    28
    Trophy Points:
    18
    Location:
    Gainesville, Florida
    cPanel Access Level:
    Reseller Owner
    Hello silue,

    Do you have access to a WHM panel? If you do you can edit your php options in your WHM. I strongly advise writing down the default settings before editing. This way if something goes wrong you can easily go back to the original settings.

    WHM/Service Configuration/php configuration editor
     
  7. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    569
    Likes Received:
    40
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Please check steps in mentioned below screen-shot for how to create custom php.ini for single account.

    prntscr.com/d3f01s

    Please try and update here if you have any query.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    danielpmc likes this.
Loading...

Share This Page