The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem : File Manager Creates New Files with 755 Permission!

Discussion in 'General Discussion' started by REXNET, Jan 31, 2012.

  1. REXNET

    REXNET Member

    Joined:
    Jan 31, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Francisco
    cPanel Access Level:
    Root Administrator
    Hello,

    As the title says, I got problem with new files permission which created by cPanel File Manager. I don't remember such a problem before, But I suddenly find it on my new server and after configuration.

    I'm using a cPanel/WHM on my dedicated server which is run on CloudLinux with the following addons installed: Installatron, WHMSonic & WHMXtra.

    Also I've installed some other software and scripts for managing, monitoring, security and better performance and i'll pm them on your request.

    Please help me to find the problem.

    Thanks
     
  2. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    I think you need to use the umask option. Also have a look at WHM - Service Configuration - Apache Configuration - PHP and SuExec Configuration for the current settings.
     
  3. REXNET

    REXNET Member

    Joined:
    Jan 31, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Francisco
    cPanel Access Level:
    Root Administrator
    The PHP handler is suphp and Apache suEXEC is enabled. I've Perl/CGI and Ruby enabled on my server, But all files with any extension give 0755 permission when we create new from file manager.

    I've checked for umask and added "umask 022" at the end of "/usr/local/apache/bin/envvars" file, After restarting Apache the problem still remain... (A file named "umask" has been created at "/var/cpanel/easy/apache/rawenv/" with value of "022" to save the settings after apache rebuild)
     
    #3 REXNET, Feb 1, 2012
    Last edited: Feb 1, 2012
  4. REXNET

    REXNET Member

    Joined:
    Jan 31, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Francisco
    cPanel Access Level:
    Root Administrator
    Is there anyone else able to help me with this problem?!
     
  5. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've added this:

    # Infopro Was Here
    umask 022

    To the very bottom under everything else of this file:
    /etc/bashrc

    Created a new file on the account via File Manager, result: 644
    Created a new folder on the account via File Manager, result: 755


    I'm not sure if its possible but if there was some sort of check to add this, or not, I think it might be useful.

    Feature Request maybe?
     
  7. REXNET

    REXNET Member

    Joined:
    Jan 31, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Francisco
    cPanel Access Level:
    Root Administrator
    Thank you all, but unfortunately it couldn't fix the problem. Should i restart any service or reboot the system?!

    Do you think some software or services on the service cause this?!
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Did you log out of the account and then back in to check?
     
  9. REXNET

    REXNET Member

    Joined:
    Jan 31, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Francisco
    cPanel Access Level:
    Root Administrator
    No, But i did and result was same before...
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I should know better than to get into a topic and suggest changes that I'm not completely familiar with.

    Looking for other threads on this very forum via google we find lots of results.

    Looking at a few of those posts there are mentions of checking this file if running SuPHP:
    /opt/suphp/etc/suphp.conf

    ...for this:

    ;Umask to set, specify in octal notation
    umask=0022
     
  11. REXNET

    REXNET Member

    Joined:
    Jan 31, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Francisco
    cPanel Access Level:
    Root Administrator
    The setting is same, 0022... Thank you any way, I should search more...
     
Loading...

Share This Page